[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] Trouble getting ARM Linux kernel to boot

From: Steven Frank
Subject: [Qemu-discuss] Trouble getting ARM Linux kernel to boot
Date: Fri, 21 Sep 2012 11:36:06 -0700


This is my first time using QEMU, so please bear with me.

I am using a Mac OS X host to build the Linux 3.5 kernel for ARM, and trying to 
boot it in QEMU 1.2.0.

The kernel, to my surprise, built fine on my Mac using the arm-none-eabi-gcc 
toolchain from MacPorts.  I'm using the versatile_defconfig, since that turned 
up a lot when I was Googling how to do this.

Then I try to boot my kernel in QEMU using this command line:

        arm-softmmu/qemu-system-arm -m 16 -M versatilepb -kernel 
arch/arm/boot/zImage -serial stdio

I don't have a rootfs yet -- I was hoping to just get as far as seeing the 
kernel boot messages.

It outputs this:

        Uncompressing Linux... done, booting the kernel.

Then hangs, with an empty white window.  Nothing further appears to happen.

I also tried building the kernel the same way _on_ Linux using VMWare, just to 
rule out the possibility that compiling on a Mac caused the problem.  QEMU 
behaves the same way with that kernel.

I also tried starting QEMU with more RAM for the virtual machine, and I also 
tried building the kernel for the ARM Integrator platform and using that with 
QEMU, with similar results.

Anyone know what I might be doing wrong?

Thanks for any help,


Attachment: smime.p7s
Description: S/MIME cryptographic signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]