[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] accessing cd image, solaris 2.5.1

From: Jakob Bohm
Subject: Re: [Qemu-discuss] accessing cd image, solaris 2.5.1
Date: Tue, 18 Sep 2012 15:03:17 +0200
User-agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:14.0) Gecko/20120713 Thunderbird/14.0

On 9/17/2012 8:34 PM, Basil Huffman wrote:
Hello all, I used Artyom Tarasenko's tutorial on installing Solaris on qemu. I have Solaris 2.5.1 installed to a disk image. I now need to install some software, from cd onto my disk image.

I have made an iso of the cd and have tried to access it by doing the following:

1. qemu-system-sparc -M SS-5 -m 256 -nographic -bios ss5.bin -hdb solaris.disk -cdrom CD.iso

I try to mount it via (as instructions from the software): "mount -o ro -F hsfs /dev/sr0 /mnt"

And the following error message is displayed:

mount: /dev/sr0 is already mounted, /mnt is busy,
        or allowable number of mount points exceeded

2. qemu-system-sparc -M SS-5 -m 256 -nographic -bios ss5.bin -hdb solaris.disk -hdc CD.iso

I then tried this method, as Artyom mentions that there are some cd issues when dealing with Solaris 2.5.1 (I had to install to the disk via a manner similar to this).

I then try to mount it via: "mount /dev/dsk/c0t2d0s0 /mnt"

But the following error message is displayed:

nfs mount: nfs file system; use host:path

I am unsure if my issue is with qemu, with solaris, or a combination of both. How can I go about accessing and mounting the cd image?


I think your problem is with Solaris and its famous automounter.

In your first attempt, Solaris had probably already mounted the CD for
you, typing mount with no arguments should help you figure out where it
is mounted.

In your second attempt, you probably ran into some more tricky Solaris
mount problems, which I don't know about.

Another possibility for both attempts is if Solaris is already using
the directory "/mnt" for its own purposes, so try a different location.


Jakob Bohm, CIO, Partner, WiseMo A/S.  http://www.wisemo.com
Transformervej 29, 2730 Herlev, Denmark.  Direct +45 31 13 16 10
This public discussion message is non-binding and may contain errors.
WiseMo - Remote Service Management for PCs, Phones and Embedded

reply via email to

[Prev in Thread] Current Thread [Next in Thread]