[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-discuss] Qemu and hard drives >2TB

From: Mike Lovell
Subject: Re: [Qemu-discuss] Qemu and hard drives >2TB
Date: Wed, 11 Jan 2012 10:43:20 -0700
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20111108 Lightning/1.0b2 Thunderbird/3.1.16

On 01/08/2012 02:30 PM, Christian Lerrahn wrote:
I've used Qemu in the past to install NetBSD from a Linux system.
However, the problem I'm facing now is that I need to install to a 3TB
hard drive and Qemu will only recognise 2TB. Not only can I not used
GPT but it never even sees the drive at its full size (which a non-gpt
fdisk will).

I've tried different versions of Qemu but possibly not the absolutely
latest one. Is there any version that can handle a hard drive this size?

are you saying that the guest only sees a hard drive of 2TB even though the device on the host is 3TB? if that is the case, then it might be that you need to try a newer version of qemu. though, i did just try a simple test and was able to see a 3TB device in the guest using qemu-kvm 0.12.5 that came with ubuntu 10.10 and with 1.0 compiled from source.

qemu should be able to see the full size of the disk. booting from it would be another question. i doubt seabios would have the ability to boot from something not using a mbr partition table. there are two potential options that i see but i have tried neither.

one would be to use a hybrid gpt/mbr partitioning configuration. gpt leaves the first block of a disk untouched and an mbr can be put in that space so its possible to have both mbr and gpt on a disk at once. gptsync is a tool that can read a gpt partition table and write the equivalent mbr to the same disk with a few limitations. maybe you could make a small partition at the beginning of the disk to boot off of and then use the remainder as a data volume. i don't know if netbsd supports hybrid gpt/mbr partition tables though so this may not even be an option. googling 'hybrid mbr' should provide more info.

the second option would be to try and use the uefi firmware that the tianocore project has for qemu. the subproject is called OVMF and http://sourceforge.net/apps/mediawiki/tianocore/index.php?title=How_to_run_OVMF has details about how to run that.

hopefully those give you a few things you could try to get this working. i've never used netbsd so i can't say how it will react to either of these nor have i spend enough time with either of these options to see that they work in other scenarios. but hopefully it will get you pointed somewhere where you can look to figure something out.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]