[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v2 18/23] migration/multifd: Rewrite multifd_queue_page()
From: |
Fabiano Rosas |
Subject: |
Re: [PATCH v2 18/23] migration/multifd: Rewrite multifd_queue_page() |
Date: |
Fri, 02 Feb 2024 17:47:05 -0300 |
peterx@redhat.com writes:
> From: Peter Xu <peterx@redhat.com>
>
> The current multifd_queue_page() is not easy to read and follow. It is not
> good with a few reasons:
>
> - No helper at all to show what exactly does a condition mean; in short,
> readability is low.
>
> - Rely on pages->ramblock being cleared to detect an empty queue. It's
> slightly an overload of the ramblock pointer, per Fabiano [1], which I
> also agree.
>
> - Contains a self recursion, even if not necessary..
>
> Rewrite this function. We add some comments to make it even clearer on
> what it does.
>
> [1] https://lore.kernel.org/r/87wmrpjzew.fsf@suse.de
>
> Signed-off-by: Peter Xu <peterx@redhat.com>
Reviewed-by: Fabiano Rosas <farosas@suse.de>
Patch looks good, but I have a question below.
> ---
> migration/multifd.c | 56 ++++++++++++++++++++++++++++++---------------
> 1 file changed, 37 insertions(+), 19 deletions(-)
>
> diff --git a/migration/multifd.c b/migration/multifd.c
> index 35d4e8ad1f..4ab8e6eff2 100644
> --- a/migration/multifd.c
> +++ b/migration/multifd.c
> @@ -506,35 +506,53 @@ static bool multifd_send_pages(void)
> return true;
> }
>
> +static inline bool multifd_queue_empty(MultiFDPages_t *pages)
> +{
> + return pages->num == 0;
> +}
> +
> +static inline bool multifd_queue_full(MultiFDPages_t *pages)
> +{
> + return pages->num == pages->allocated;
> +}
> +
> +static inline void multifd_enqueue(MultiFDPages_t *pages, ram_addr_t offset)
> +{
> + pages->offset[pages->num++] = offset;
> +}
> +
> /* Returns true if enqueue successful, false otherwise */
> bool multifd_queue_page(RAMBlock *block, ram_addr_t offset)
> {
> - MultiFDPages_t *pages = multifd_send_state->pages;
> - bool changed = false;
> + MultiFDPages_t *pages;
> +
> +retry:
> + pages = multifd_send_state->pages;
>
> - if (!pages->block) {
> + /* If the queue is empty, we can already enqueue now */
> + if (multifd_queue_empty(pages)) {
> pages->block = block;
> + multifd_enqueue(pages, offset);
> + return true;
> }
>
> - if (pages->block == block) {
> - pages->offset[pages->num] = offset;
> - pages->num++;
> -
> - if (pages->num < pages->allocated) {
> - return true;
> + /*
> + * Not empty, meanwhile we need a flush. It can because of either:
> + *
> + * (1) The page is not on the same ramblock of previous ones, or,
> + * (2) The queue is full.
> + *
> + * After flush, always retry.
> + */
> + if (pages->block != block || multifd_queue_full(pages)) {
> + if (!multifd_send_pages()) {
> + return false;
> }
> - } else {
> - changed = true;
> - }
> -
> - if (!multifd_send_pages()) {
> - return false;
> - }
> -
> - if (changed) {
> - return multifd_queue_page(block, offset);
> + goto retry;
> }
>
> + /* Not empty, and we still have space, do it! */
> + multifd_enqueue(pages, offset);
Hm, here you're missing the flush of the last group of pages of the last
ramblock. Just like current code...
...which means we're relying on the multifd_send_pages() at
multifd_send_sync_main() to send the last few pages. So how can that
work when multifd_flush_after_each_section==false? Because it skips the
sync flag, but would also skip the last send. I'm confused.
- Re: [PATCH v2 13/23] migration/multifd: Move header prepare/fill into send_prepare(), (continued)
- [PATCH v2 12/23] migration/multifd: multifd_send_prepare_header(), peterx, 2024/02/02
- [PATCH v2 14/23] migration/multifd: Forbid spurious wakeups, peterx, 2024/02/02
- [PATCH v2 15/23] migration/multifd: Split multifd_send_terminate_threads(), peterx, 2024/02/02
- [PATCH v2 17/23] migration/multifd: Change retval of multifd_send_pages(), peterx, 2024/02/02
- [PATCH v2 16/23] migration/multifd: Change retval of multifd_queue_page(), peterx, 2024/02/02
- [PATCH v2 18/23] migration/multifd: Rewrite multifd_queue_page(), peterx, 2024/02/02
- Re: [PATCH v2 18/23] migration/multifd: Rewrite multifd_queue_page(),
Fabiano Rosas <=
- [PATCH v2 19/23] migration/multifd: Cleanup multifd_save_cleanup(), peterx, 2024/02/02
- [PATCH v2 20/23] migration/multifd: Cleanup multifd_load_cleanup(), peterx, 2024/02/02
- [PATCH v2 21/23] migration/multifd: Stick with send/recv on function names, peterx, 2024/02/02
- [PATCH v2 22/23] migration/multifd: Fix MultiFDSendParams.packet_num race, peterx, 2024/02/02