qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v6 1/3] multifd: Create property multifd-flush-after-each-sec


From: Juan Quintela
Subject: Re: [PATCH v6 1/3] multifd: Create property multifd-flush-after-each-section
Date: Wed, 15 Feb 2023 21:13:39 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Peter Xu <peterx@redhat.com> wrote:
> On Wed, Feb 15, 2023 at 07:02:29PM +0100, Juan Quintela wrote:
>> We used to flush all channels at the end of each RAM section
>> sent.  That is not needed, so preparing to only flush after a full
>> iteration through all the RAM.
>> 
>> Default value of the property is false.  But we return "true" in
>> migrate_multifd_flush_after_each_section() until we implement the code
>> in following patches.
>> 
>> Signed-off-by: Juan Quintela <quintela@redhat.com>
>
> This line can be dropped, after (I assume) git commit helped to add the
> other one below. :)

Gree, git and trailers is always so much fun.  Will try to fix them (again)

>
> Normally that's also why I put R-bs before my SoB because I should have two
> SoB but then I merge them into the last; git is happy with that too.
>
>> Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
>> Signed-off-by: Juan Quintela <quintela@redhat.com>
>
> Acked-by: Peter Xu <peterx@redhat.com>

Thanks.

> But some nitpicks below (I'll leave those to you to decide whether to
> rework or keep them as is..).
>
>>
>> ---
>> 
>> Rename each-iteration to after-each-section
>> Rename multifd-sync-after-each-section to
>>        multifd-flush-after-each-section
>> ---
>>  qapi/migration.json   | 21 ++++++++++++++++++++-
>>  migration/migration.h |  1 +
>>  hw/core/machine.c     |  1 +
>>  migration/migration.c | 17 +++++++++++++++--
>>  4 files changed, 37 insertions(+), 3 deletions(-)
>> 
>> diff --git a/qapi/migration.json b/qapi/migration.json
>> index c84fa10e86..3afd81174d 100644
>> --- a/qapi/migration.json
>> +++ b/qapi/migration.json
>> @@ -478,6 +478,24 @@
>>  #                    should not affect the correctness of postcopy 
>> migration.
>>  #                    (since 7.1)
>>  #
>> +# @multifd-flush-after-each-section: flush every channel after each
>> +#                                    section sent.  This assures that
>> +#                                    we can't mix pages from one
>> +#                                    iteration through ram pages with
>> +#                                    pages for the following
>> +#                                    iteration.  We really only need
>> +#                                    to do this flush after we have go
>> +#                                    through all the dirty pages.
>> +#                                    For historical reasons, we do
>> +#                                    that after each section.  This is
>> +#                                    suboptimal (we flush too many
>> +#                                    times).
>> +#                                    Default value is false.
>> +#                                    Setting this capability has no
>> +#                                    effect until the patch that
>> +#                                    removes this comment.
>> +#                                    (since 8.0)
>
> IMHO the core of this new "cap" is the new RAM_SAVE_FLAG_MULTIFD_FLUSH bit
> in the stream protocol, but it's not referenced here.  I would suggest
> simplify the content but highlight the core change:

Actually it is the other way around.  What this capability will do is
_NOT_ use RAM_SAVE_FLAG_MULTIFD_FLUSH protocol.

>  @multifd-lazy-flush:  When enabled, multifd will only do sync flush after
>                        each whole round of bitmap scan.  Otherwise it'll be
>                        done per RAM save iteration (which happens with a much
>                        higher frequency).
>
>                        Please consider enable this as long as possible, and
>                        keep this off only if any of the src/dst QEMU binary
>                        doesn't support it.
>
>                        This capability is bound to the new RAM save flag
>                        RAM_SAVE_FLAG_MULTIFD_FLUSH, the new flag will only
>                        be used and recognized when this feature bit set.

Name is wrong.  It would be multifd-non-lazy-flush.  And I don't like
negatives.  Real name is:

multifd-I-messed-and-flush-too-many-times.


> I know you dislike multifd-lazy-flush, but that's still the best I can come
> up with when writting this (yeah I still like it :-p), please bare with me
> and take whatever you think the best.

Libvirt assumes that all capabilities are false except if enabled.
We want RAM_SAVE_FLAG_MULTFD_FLUSH by default (in new machine types).

So, if we can do

capability_use_new_way = true

We change that to

capability_use_old_way = true

And then by default with false value is what we want.

>> +bool migrate_multifd_flush_after_each_section(void)
>> +{
>> +    MigrationState *s = migrate_get_current();
>> +
>> +    /*
>> +     * Until the patch that remove this comment, we always return that
>> +     * the capability is enabled.
>> +     */
>> +    return true || 
>> s->enabled_capabilities[MIGRATION_CAPABILITY_MULTIFD_FLUSH_AFTER_EACH_SECTION];
>
> (I'd rather not care about what happens if someone applies only this patch
>  not the latter two by dropping "true ||" directly here, but again, no a
>  huge deal)
>
>> +}

It don't matter at all.

Patch1: Introduces the code for a capability, but nothing else.
        It makes the capability be true always (remember old code)
Patch2: Makes old code conditional on this capability (see that we have
        force it to be true).
Patch3: Introduce code for the new capability, and "protect" it for the
        capability being false.  We can remove the "trick" that we just
        had.

See discussion on v5 with Markus for more details.

Later, Juan.

>> +
>>  bool migrate_pause_before_switchover(void)
>>  {
>>      MigrationState *s;
>> @@ -4535,7 +4547,8 @@ static Property migration_properties[] = {
>>      DEFINE_PROP_MIG_CAP("x-zero-copy-send",
>>              MIGRATION_CAPABILITY_ZERO_COPY_SEND),
>>  #endif
>> -
>> +    DEFINE_PROP_MIG_CAP("multifd-flush-after-each-section",
>> +                        
>> MIGRATION_CAPABILITY_MULTIFD_FLUSH_AFTER_EACH_SECTION),
>>      DEFINE_PROP_END_OF_LIST(),
>>  };
>>  
>> -- 
>> 2.39.1
>> 
>> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]