[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 02/11] python/qemu: rename command() to cmd()
From: |
Daniel P . Berrangé |
Subject: |
Re: [PATCH v4 02/11] python/qemu: rename command() to cmd() |
Date: |
Tue, 10 Jan 2023 10:53:28 +0000 |
User-agent: |
Mutt/2.2.9 (2022-11-12) |
On Tue, Jan 10, 2023 at 11:37:49AM +0300, Vladimir Sementsov-Ogievskiy wrote:
> Use a shorter name. We are going to move in iotests from qmp() to
> command() where possible. But command() is longer than qmp() and don't
> look better. Let's rename.
>
> You can simply grep for '\.command(' and for 'def command(' to check
> that everything is updated (command() in tests/docker/docker.py is
> unrelated).
>
> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
> ---
> docs/devel/testing.rst | 10 +-
> python/qemu/machine/machine.py | 8 +-
> python/qemu/qmp/legacy.py | 2 +-
> python/qemu/qmp/qmp_shell.py | 2 +-
> python/qemu/utils/qemu_ga_client.py | 2 +-
> python/qemu/utils/qom.py | 8 +-
> python/qemu/utils/qom_common.py | 2 +-
> python/qemu/utils/qom_fuse.py | 6 +-
> scripts/cpu-x86-uarch-abi.py | 8 +-
> scripts/device-crash-test | 8 +-
> scripts/render_block_graph.py | 8 +-
> tests/avocado/avocado_qemu/__init__.py | 4 +-
> tests/avocado/cpu_queries.py | 5 +-
> tests/avocado/hotplug_cpu.py | 10 +-
> tests/avocado/info_usernet.py | 4 +-
> tests/avocado/machine_arm_integratorcp.py | 6 +-
> tests/avocado/machine_m68k_nextcube.py | 4 +-
> tests/avocado/machine_mips_malta.py | 6 +-
> tests/avocado/machine_s390_ccw_virtio.py | 28 ++--
> tests/avocado/migration.py | 10 +-
> tests/avocado/pc_cpu_hotplug_props.py | 2 +-
> tests/avocado/version.py | 4 +-
> tests/avocado/virtio_check_params.py | 6 +-
> tests/avocado/virtio_version.py | 5 +-
> tests/avocado/x86_cpu_model_versions.py | 13 +-
> tests/migration/guestperf/engine.py | 150 +++++++++++-----------
> tests/qemu-iotests/256 | 34 ++---
> tests/qemu-iotests/257 | 36 +++---
> 28 files changed, 198 insertions(+), 193 deletions(-)
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
With regards,
Daniel
--
|: https://berrange.com -o- https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org -o- https://fstop138.berrange.com :|
|: https://entangle-photo.org -o- https://www.instagram.com/dberrange :|
- [PATCH v4 00/11] iotests: use vm.cmd(), Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 01/11] python: rename QEMUMonitorProtocol.cmd() to cmd_raw(), Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 03/11] python/machine.py: upgrade vm.cmd() method, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 04/11] iotests: QemuStorageDaemon: add cmd() method like in QEMUMachine., Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 02/11] python/qemu: rename command() to cmd(), Vladimir Sementsov-Ogievskiy, 2023/01/10
- Re: [PATCH v4 02/11] python/qemu: rename command() to cmd(),
Daniel P . Berrangé <=
- [PATCH v4 05/11] iotests: add some missed checks of qmp result, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 06/11] iotests: refactor some common qmp result checks into generic pattern, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 07/11] iotests: drop some occasional semicolons, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 08/11] iotests: drop some extra ** in qmp() call, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 09/11] iotests.py: pause_job(): drop return value, Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 10/11] tests/vm/basevm.py: use cmd() instead of qmp(), Vladimir Sementsov-Ogievskiy, 2023/01/10
- [PATCH v4 11/11] python: use vm.cmd() instead of vm.qmp() where appropriate, Vladimir Sementsov-Ogievskiy, 2023/01/10