qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 18/23] multifd: Use normal pages array on the recv side


From: Juan Quintela
Subject: Re: [PATCH v3 18/23] multifd: Use normal pages array on the recv side
Date: Fri, 10 Dec 2021 11:41:41 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.2 (gnu/linux)

Peter Xu <peterx@redhat.com> wrote:
> On Wed, Nov 24, 2021 at 11:06:12AM +0100, Juan Quintela wrote:
>> Signed-off-by: Juan Quintela <quintela@redhat.com>
>> ---
>>  migration/multifd.h      |  8 +++++--
>>  migration/multifd-zlib.c |  8 +++----
>>  migration/multifd-zstd.c |  6 +++---
>>  migration/multifd.c      | 45 ++++++++++++++++++----------------------
>>  4 files changed, 33 insertions(+), 34 deletions(-)
>> 
>> diff --git a/migration/multifd.h b/migration/multifd.h
>> index 78e73df3ec..9fbcb7bb9a 100644
>> --- a/migration/multifd.h
>> +++ b/migration/multifd.h
>> @@ -151,12 +151,16 @@ typedef struct {
>>      uint32_t next_packet_size;
>>      /* packets sent through this channel */
>>      uint64_t num_packets;
>> -    /* pages sent through this channel */
>> -    uint64_t num_pages;
>> +    /* non zero pages sent through this channel */
>
> s/send/recv/

Thanks.

>> +    uint64_t num_normal_pages;
>
> How about renaming it to "total_normal_pages"?  It's merely impossible to
> identify this from normal_num below from their names..

I can change it.  It just makes some lines a bit longer, but that is
what you have with better names.

> I'd have the same comment to previous patch.

Ok.

Thanks, Juan.

>
> Thanks,
>
>>      /* syncs main thread and channels */
>>      QemuSemaphore sem_sync;
>>      /* buffers to recv */
>>      struct iovec *iov;
>> +    /* Pages that are not zero */
>> +    ram_addr_t *normal;
>> +    /* num of non zero pages */
>> +    uint32_t normal_num;
>>      /* used for de-compression methods */
>>      void *data;
>>  } MultiFDRecvParams;




reply via email to

[Prev in Thread] Current Thread [Next in Thread]