qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 20/23] multifd: Rename pages_used to normal_pages


From: Dr. David Alan Gilbert
Subject: Re: [PATCH v3 20/23] multifd: Rename pages_used to normal_pages
Date: Wed, 1 Dec 2021 19:00:16 +0000
User-agent: Mutt/2.1.3 (2021-09-10)

* Juan Quintela (quintela@redhat.com) wrote:
> Signed-off-by: Juan Quintela <quintela@redhat.com>

Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com>

(This series has a painful lot of small renamy patches)


> ---
>  migration/multifd.h | 3 ++-
>  migration/multifd.c | 4 ++--
>  2 files changed, 4 insertions(+), 3 deletions(-)
> 
> diff --git a/migration/multifd.h b/migration/multifd.h
> index ab32baebd7..39e55d7f05 100644
> --- a/migration/multifd.h
> +++ b/migration/multifd.h
> @@ -44,7 +44,8 @@ typedef struct {
>      uint32_t flags;
>      /* maximum number of allocated pages */
>      uint32_t pages_alloc;
> -    uint32_t pages_used;
> +    /* non zero pages */
> +    uint32_t normal_pages;
>      /* size of the next packet that contains pages */
>      uint32_t next_packet_size;
>      uint64_t packet_num;
> diff --git a/migration/multifd.c b/migration/multifd.c
> index dc76322137..d1ab823f98 100644
> --- a/migration/multifd.c
> +++ b/migration/multifd.c
> @@ -262,7 +262,7 @@ static void multifd_send_fill_packet(MultiFDSendParams *p)
>  
>      packet->flags = cpu_to_be32(p->flags);
>      packet->pages_alloc = cpu_to_be32(p->pages->allocated);
> -    packet->pages_used = cpu_to_be32(p->normal_num);
> +    packet->normal_pages = cpu_to_be32(p->normal_num);
>      packet->next_packet_size = cpu_to_be32(p->next_packet_size);
>      packet->packet_num = cpu_to_be64(p->packet_num);
>  
> @@ -316,7 +316,7 @@ static int multifd_recv_unfill_packet(MultiFDRecvParams 
> *p, Error **errp)
>          return -1;
>      }
>  
> -    p->normal_num = be32_to_cpu(packet->pages_used);
> +    p->normal_num = be32_to_cpu(packet->normal_pages);
>      if (p->normal_num > packet->pages_alloc) {
>          error_setg(errp, "multifd: received packet "
>                     "with %d pages and expected maximum pages are %d",
> -- 
> 2.33.1
> 
-- 
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK




reply via email to

[Prev in Thread] Current Thread [Next in Thread]