[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v6 26/30] hw/intc/sh_intc: Remove unneeded local variable initial
From: |
BALATON Zoltan |
Subject: |
[PATCH v6 26/30] hw/intc/sh_intc: Remove unneeded local variable initialisers |
Date: |
Fri, 29 Oct 2021 23:02:09 +0200 |
The sh_intc_locate function will either init these or not return so no
need to initialise them.
Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
---
hw/intc/sh_intc.c | 21 ++++++++++-----------
1 file changed, 10 insertions(+), 11 deletions(-)
diff --git a/hw/intc/sh_intc.c b/hw/intc/sh_intc.c
index 3603b448c2..1c30988437 100644
--- a/hw/intc/sh_intc.c
+++ b/hw/intc/sh_intc.c
@@ -196,14 +196,13 @@ static void sh_intc_toggle_mask(struct intc_desc *desc,
intc_enum id,
}
}
-static uint64_t sh_intc_read(void *opaque, hwaddr offset,
- unsigned size)
+static uint64_t sh_intc_read(void *opaque, hwaddr offset, unsigned size)
{
struct intc_desc *desc = opaque;
- intc_enum *enum_ids = NULL;
- unsigned int first = 0;
- unsigned int width = 0;
- unsigned int mode = 0;
+ intc_enum *enum_ids;
+ unsigned int first;
+ unsigned int width;
+ unsigned int mode;
unsigned long *valuep;
sh_intc_locate(desc, (unsigned long)offset, &valuep,
@@ -216,12 +215,12 @@ static void sh_intc_write(void *opaque, hwaddr offset,
uint64_t value, unsigned size)
{
struct intc_desc *desc = opaque;
- intc_enum *enum_ids = NULL;
- unsigned int first = 0;
- unsigned int width = 0;
- unsigned int mode = 0;
- unsigned int k;
+ intc_enum *enum_ids;
+ unsigned int first;
+ unsigned int width;
+ unsigned int mode;
unsigned long *valuep;
+ unsigned int k;
unsigned long mask;
trace_sh_intc_write(size, offset, value);
--
2.21.4
- [PATCH v6 03/30] hw/sh4: Coding style: White space fixes, (continued)
- [PATCH v6 03/30] hw/sh4: Coding style: White space fixes, BALATON Zoltan, 2021/10/29
- [PATCH v6 20/30] hw/intc/sh_intc: Remove excessive parenthesis, BALATON Zoltan, 2021/10/29
- [PATCH v6 16/30] hw/intc/sh_intc: Turn some defines into an enum, BALATON Zoltan, 2021/10/29
- [PATCH v6 18/30] hw/intc/sh_intc: Drop another useless macro, BALATON Zoltan, 2021/10/29
- [PATCH v6 14/30] hw/char/sh_serial: Add device id to trace output, BALATON Zoltan, 2021/10/29
- [PATCH v6 23/30] hw/intc/sh_intc: Replace abort() with g_assert_not_reached(), BALATON Zoltan, 2021/10/29
- [PATCH v6 24/30] hw/intc/sh_intc: Avoid using continue in loops, BALATON Zoltan, 2021/10/29
- [PATCH v6 28/30] hw/timer/sh_timer: Do not wrap lines that are not too long, BALATON Zoltan, 2021/10/29
- [PATCH v6 25/30] hw/intc/sh_intc: Simplify allocating sources array, BALATON Zoltan, 2021/10/29
- [PATCH v6 26/30] hw/intc/sh_intc: Remove unneeded local variable initialisers,
BALATON Zoltan <=
- [PATCH v6 27/30] hw/timer/sh_timer: Rename sh_timer_state to SHTimerState, BALATON Zoltan, 2021/10/29
- [PATCH v6 30/30] hw/timer/sh_timer: Remove use of hw_error, BALATON Zoltan, 2021/10/29
- [PATCH v6 29/30] hw/timer/sh_timer: Fix timer memory region size, BALATON Zoltan, 2021/10/29
- [PATCH v7 29/30] hw/timer/sh_timer: Fix timer memory region size, BALATON Zoltan, 2021/10/29