[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 10/11] hw/intc/sh_intc: Clean up iomem region
From: |
BALATON Zoltan |
Subject: |
[PATCH v2 10/11] hw/intc/sh_intc: Clean up iomem region |
Date: |
Wed, 27 Oct 2021 15:46:17 +0200 |
Fix the size of the iomem region and rename it to "intc" from
"interrupt-controller" which makes the info mtree output less wide as
it is already too wide because of all the aliases. Also drop the
format macro which was only used twice in close proximity so we can
just use the literal string instead without a macro definition.
Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
---
hw/intc/sh_intc.c | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/hw/intc/sh_intc.c b/hw/intc/sh_intc.c
index 18461ff554..fc1905f299 100644
--- a/hw/intc/sh_intc.c
+++ b/hw/intc/sh_intc.c
@@ -288,15 +288,13 @@ static unsigned int sh_intc_register(MemoryRegion *sysmem,
iomem_p4 = desc->iomem_aliases + index;
iomem_a7 = iomem_p4 + 1;
-#define SH_INTC_IOMEM_FORMAT "interrupt-controller-%s-%s-%s"
- snprintf(name, sizeof(name), SH_INTC_IOMEM_FORMAT, type, action, "p4");
+ snprintf(name, sizeof(name), "intc-%s-%s-%s", type, action, "p4");
memory_region_init_alias(iomem_p4, NULL, name, iomem, A7ADDR(address), 4);
memory_region_add_subregion(sysmem, P4ADDR(address), iomem_p4);
- snprintf(name, sizeof(name), SH_INTC_IOMEM_FORMAT, type, action, "a7");
+ snprintf(name, sizeof(name), "intc-%s-%s-%s", type, action, "a7");
memory_region_init_alias(iomem_a7, NULL, name, iomem, A7ADDR(address), 4);
memory_region_add_subregion(sysmem, A7ADDR(address), iomem_a7);
-#undef SH_INTC_IOMEM_FORMAT
/* used to increment aliases index */
return 2;
@@ -432,9 +430,7 @@ int sh_intc_init(MemoryRegion *sysmem,
}
desc->irqs = qemu_allocate_irqs(sh_intc_set_irq, desc, nr_sources);
-
- memory_region_init_io(&desc->iomem, NULL, &sh_intc_ops, desc,
- "interrupt-controller", 0x100000000ULL);
+ memory_region_init_io(&desc->iomem, NULL, &sh_intc_ops, desc, "intc", 4);
#define INT_REG_PARAMS(reg_struct, type, action, j) \
reg_struct->action##_reg, #type, #action, j
--
2.21.4
- [PATCH v2 00/11] More SH4 clean ups, BALATON Zoltan, 2021/10/27
- [PATCH v2 04/11] hw/sh4/r2d: Use error_report instead of fprintf to stderr, BALATON Zoltan, 2021/10/27
- [PATCH v2 05/11] hw/char/sh_serial: Rename type sh_serial_state to SHSerialState, BALATON Zoltan, 2021/10/27
- [PATCH v2 01/11] hw/sh4: Fix a typo in a comment, BALATON Zoltan, 2021/10/27
- [PATCH v2 10/11] hw/intc/sh_intc: Clean up iomem region,
BALATON Zoltan <=
- [PATCH v2 11/11] hw/intc/sh_intc: Drop another useless macro, BALATON Zoltan, 2021/10/27
- [PATCH v2 02/11] hw//sh4: Use qemu_log instead of fprintf to stderr, BALATON Zoltan, 2021/10/27
- [PATCH v2 06/11] hw/char/sh_serial: QOM-ify, BALATON Zoltan, 2021/10/27
- [PATCH v2 07/11] hw/char/sh_serial: Add device id to trace output, BALATON Zoltan, 2021/10/27