[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 08/10] block/nbd: rename NBDConnectThread to NBDClientConn

From: Roman Kagan
Subject: Re: [PATCH v2 08/10] block/nbd: rename NBDConnectThread to NBDClientConnection
Date: Thu, 8 Apr 2021 19:54:16 +0300

On Thu, Apr 08, 2021 at 05:08:25PM +0300, Vladimir Sementsov-Ogievskiy wrote:
> We are going to move connection code to own file and want clear names
> and APIs.
> The structure is shared between user and (possibly) several runs of
> connect-thread. So it's wrong to call it "thread". Let's rename to
> something more generic.
> Appropriately rename connect_thread and thr variables to conn.
> connect_thread_state_unref() function gets new appropriate name too
> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
> ---
>  block/nbd.c | 127 ++++++++++++++++++++++++++--------------------------
>  1 file changed, 63 insertions(+), 64 deletions(-)

[To other reviewers: in addition to renaming there's one blank line
removed, hence the difference between (+) and (-)]

Reviewed-by: Roman Kagan <rvkagan@yandex-team.ru>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]