[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 21/29] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd()
From: |
Markus Armbruster |
Subject: |
[PULL 21/29] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd() |
Date: |
Tue, 23 Mar 2021 22:56:50 +0100 |
Commit 967c885108 "qapi: add 'if' to top-level expressions" added
command TestIfCmd with an 'if' condition. It also added the
qmp_TestIfCmd() to go with it, guarded by the corresponding #if.
Commit ccadd6bcba "qapi: Add 'if' to implicit struct members" changed
the command, but not the function. Compiles only because we don't
satisfy the #if. Instead of fixing the function, simply drop it.
Signed-off-by: Markus Armbruster <armbru@redhat.com>
Message-Id: <20210323094025.3569441-22-armbru@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
---
tests/unit/test-qmp-cmds.c | 7 -------
1 file changed, 7 deletions(-)
diff --git a/tests/unit/test-qmp-cmds.c b/tests/unit/test-qmp-cmds.c
index 266db074b4..99973dde7c 100644
--- a/tests/unit/test-qmp-cmds.c
+++ b/tests/unit/test-qmp-cmds.c
@@ -13,13 +13,6 @@
static QmpCommandList qmp_commands;
-#if defined(TEST_IF_STRUCT) && defined(TEST_IF_CMD)
-UserDefThree *qmp_TestIfCmd(TestIfStruct *foo, Error **errp)
-{
- return NULL;
-}
-#endif
-
UserDefThree *qmp_TestCmdReturnDefThree(Error **errp)
{
return NULL;
--
2.26.3
- [PULL 07/29] qapi: Fix to reject optional members with reserved names, (continued)
- [PULL 07/29] qapi: Fix to reject optional members with reserved names, Markus Armbruster, 2021/03/23
- [PULL 06/29] tests/qapi-schema: Tweak to demonstrate buggy member name check, Markus Armbruster, 2021/03/23
- [PULL 05/29] tests/qapi-schema: Drop TODO comment on simple unions, Markus Armbruster, 2021/03/23
- [PULL 03/29] tests/qapi-schema: Rework comments on longhand member definitions, Markus Armbruster, 2021/03/23
- [PULL 02/29] tests/qapi-schema: Drop redundant flat-union-inline test, Markus Armbruster, 2021/03/23
- [PULL 04/29] tests/qapi-schema: Belatedly update comment on alternate clash, Markus Armbruster, 2021/03/23
- [PULL 18/29] tests/qapi-schema: Rename returns-whitelist to returns-bad-type, Markus Armbruster, 2021/03/23
- [PULL 14/29] qapi: Enforce type naming rules, Markus Armbruster, 2021/03/23
- [PULL 15/29] tests/qapi-schema: Rename redefined-builtin to redefined-predefined, Markus Armbruster, 2021/03/23
- [PULL 23/29] qapi: Enforce feature naming rules, Markus Armbruster, 2021/03/23
- [PULL 21/29] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd(),
Markus Armbruster <=
- [PULL 12/29] qapi: Consistently permit any case in downstream prefixes, Markus Armbruster, 2021/03/23
- [PULL 16/29] qapi: Factor out QAPISchemaParser._check_pragma_list_of_str(), Markus Armbruster, 2021/03/23
- [PULL 28/29] qapi: Enforce union and alternate branch naming rules, Markus Armbruster, 2021/03/23
- [PULL 17/29] tests/qapi-schema: Rename pragma-*-crap to pragma-value-not-*, Markus Armbruster, 2021/03/23
- [PULL 09/29] qapi: Lift enum-specific code out of check_name_str(), Markus Armbruster, 2021/03/23
- [PULL 13/29] qapi: Enforce event naming rules, Markus Armbruster, 2021/03/23
- [PULL 29/29] block: Remove monitor command block_passwd, Markus Armbruster, 2021/03/23
- [PULL 22/29] qapi: Prepare for rejecting underscore in command and member names, Markus Armbruster, 2021/03/23
- [PULL 08/29] qapi: Permit flat union members for any tag value, Markus Armbruster, 2021/03/23
- [PULL 24/29] qapi: Enforce command naming rules, Markus Armbruster, 2021/03/23