[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 11/26] accel/tcg: Rename tcg_init to tcg_init_machine
From: |
Richard Henderson |
Subject: |
[PATCH 11/26] accel/tcg: Rename tcg_init to tcg_init_machine |
Date: |
Wed, 10 Mar 2021 18:21:41 -0600 |
We shortly want to use tcg_init for something else.
Since the hook is called init_machine, match that.
Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
---
accel/tcg/tcg-all.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/accel/tcg/tcg-all.c b/accel/tcg/tcg-all.c
index f132033999..30d81ff7f5 100644
--- a/accel/tcg/tcg-all.c
+++ b/accel/tcg/tcg-all.c
@@ -105,7 +105,7 @@ static void tcg_accel_instance_init(Object *obj)
bool mttcg_enabled;
-static int tcg_init(MachineState *ms)
+static int tcg_init_machine(MachineState *ms)
{
TCGState *s = TCG_STATE(current_accel());
@@ -189,7 +189,7 @@ static void tcg_accel_class_init(ObjectClass *oc, void
*data)
{
AccelClass *ac = ACCEL_CLASS(oc);
ac->name = "tcg";
- ac->init_machine = tcg_init;
+ ac->init_machine = tcg_init_machine;
ac->allowed = &tcg_allowed;
object_class_property_add_str(oc, "thread",
--
2.25.1
- [PATCH 02/26] meson: Move disas/tci.c to disas/meson.build, (continued)
- [PATCH 02/26] meson: Move disas/tci.c to disas/meson.build, Richard Henderson, 2021/03/10
- [PATCH 01/26] meson: Split out tcg/meson.build, Richard Henderson, 2021/03/10
- [PATCH 06/26] tcg: Split out tcg_region_initial_alloc, Richard Henderson, 2021/03/10
- [PATCH 07/26] tcg: Split out tcg_region_prologue_set, Richard Henderson, 2021/03/10
- [PATCH 09/26] accel/tcg: Inline cpu_gen_init, Richard Henderson, 2021/03/10
- [PATCH 08/26] tcg: Split out region.c, Richard Henderson, 2021/03/10
- [PATCH 11/26] accel/tcg: Rename tcg_init to tcg_init_machine,
Richard Henderson <=
- [PATCH 12/26] tcg: Create tcg_init, Richard Henderson, 2021/03/10
- [PATCH 14/26] accel/tcg: Pass down max_cpus to tcg_init, Richard Henderson, 2021/03/10
- [PATCH 10/26] accel/tcg: Move alloc_code_gen_buffer to tcg/region.c, Richard Henderson, 2021/03/10
- [PATCH 18/26] tcg: Tidy tcg_n_regions, Richard Henderson, 2021/03/10
- [PATCH 17/26] tcg: Replace region.end with region.total_size, Richard Henderson, 2021/03/10