[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 11/12] hw/block/pflash_cfi01: Correct the type of PFlashCFI01.
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH v2 11/12] hw/block/pflash_cfi01: Correct the type of PFlashCFI01.ro |
Date: |
Wed, 10 Mar 2021 18:05:27 +0100 |
From: David Edmondson <david.edmondson@oracle.com>
PFlashCFI01.ro is a bool, declare it as such.
Signed-off-by: David Edmondson <david.edmondson@oracle.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Message-Id: <20210216142721.1985543-3-david.edmondson@oracle.com>
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
---
hw/block/pflash_cfi01.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/block/pflash_cfi01.c b/hw/block/pflash_cfi01.c
index 32c9b289715..787466b249f 100644
--- a/hw/block/pflash_cfi01.c
+++ b/hw/block/pflash_cfi01.c
@@ -82,7 +82,7 @@ struct PFlashCFI01 {
uint8_t max_device_width; /* max device width in bytes */
uint32_t features;
uint8_t wcycle; /* if 0, the flash is read normally */
- int ro;
+ bool ro;
uint8_t cmd;
uint8_t status;
uint16_t ident0;
@@ -858,7 +858,7 @@ static void pflash_cfi01_realize(DeviceState *dev, Error
**errp)
return;
}
} else {
- pfl->ro = 0;
+ pfl->ro = false;
}
if (pfl->blk) {
--
2.26.2
- [PATCH v2 06/12] hw/block/pflash_cfi02: Rename register_memory(true) as mode_read_array, (continued)
- [PATCH v2 06/12] hw/block/pflash_cfi02: Rename register_memory(true) as mode_read_array, Philippe Mathieu-Daudé, 2021/03/10
- [PATCH v2 07/12] hw/block/pflash_cfi02: Factor out pflash_reset_state_machine(), Philippe Mathieu-Daudé, 2021/03/10
- [PATCH v2 08/12] hw/block/pflash_cfi02: Add DeviceReset method, Philippe Mathieu-Daudé, 2021/03/10
- [PATCH v2 09/12] hw/block/pflash_cfi01: Clarify trace events, Philippe Mathieu-Daudé, 2021/03/10
- [PATCH v2 10/12] hw/block/pflash_cfi01: Extract pflash_mode_read_array(), Philippe Mathieu-Daudé, 2021/03/10
- [PATCH v2 11/12] hw/block/pflash_cfi01: Correct the type of PFlashCFI01.ro,
Philippe Mathieu-Daudé <=
- [PATCH v2 12/12] hw/block/pflash_cfi: Replace DPRINTF with trace events, Philippe Mathieu-Daudé, 2021/03/10
- Re: [PATCH v2 00/12] hw/block/pflash: Refactors around setting the device in read-array mode, Philippe Mathieu-Daudé, 2021/03/15