qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 00/13] target/mips: Replace integer by MMUAccessType enum when po


From: Philippe Mathieu-Daudé
Subject: [PATCH 00/13] target/mips: Replace integer by MMUAccessType enum when possible
Date: Thu, 28 Jan 2021 15:41:12 +0100

Taking notes while reviewing commit 671a0a1265a
("use MMUAccessType instead of int in mmu_translate").

Philippe Mathieu-Daudé (13):
  target/mips: Remove access_type argument from map_address() handler
  target/mips: Remove access_type argument from get_seg_physical_address
  target/mips: Remove access_type arg from get_segctl_physical_address()
  target/mips: Remove access_type argument from get_physical_address()
  target/mips: Remove unused MMU definitions
  target/mips: Replace magic value by MMU_DATA_LOAD definition
  target/mips: Let page_table_walk_refill() take MMUAccessType argument
  target/mips: Let do_translate_address() take MMUAccessType argument
  target/mips: Let cpu_mips_translate_address() take MMUAccessType arg
  target/mips: Let raise_mmu_exception() take MMUAccessType argument
  target/mips: Let get_physical_address() take MMUAccessType argument
  target/mips: Let get_seg*_physical_address() take MMUAccessType arg
  target/mips: Let CPUMIPSTLBContext::map_address() take MMUAccessType

 target/mips/cpu.h        | 16 ---------
 target/mips/internal.h   | 10 +++---
 target/mips/op_helper.c  |  9 ++---
 target/mips/tlb_helper.c | 78 +++++++++++++++++++---------------------
 4 files changed, 47 insertions(+), 66 deletions(-)

-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]