qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 03/18] hw/pci-host/bonito: Use PCI_DEVFN() macro


From: Huacai Chen
Subject: Re: [PATCH 03/18] hw/pci-host/bonito: Use PCI_DEVFN() macro
Date: Sun, 3 Jan 2021 09:38:52 +0800

Reviewed-by: Huacai Chen <chenhuacai@kernel.org>

On Fri, Jan 1, 2021 at 6:49 AM Philippe Mathieu-Daudé <f4bug@amsat.org> wrote:
>
> Use the PCI_DEVFN() macro to replace the '0x28' magic value,
> this way it is clearer we access PCI function #0 of slot #5.
>
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
>  hw/pci-host/bonito.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/hw/pci-host/bonito.c b/hw/pci-host/bonito.c
> index efeba29011f..4c903d4f682 100644
> --- a/hw/pci-host/bonito.c
> +++ b/hw/pci-host/bonito.c
> @@ -626,7 +626,7 @@ static void bonito_pcihost_realize(DeviceState *dev, 
> Error **errp)
>      phb->bus = pci_register_root_bus(dev, "pci",
>                                       pci_bonito_set_irq, pci_bonito_map_irq,
>                                       dev, &bs->pci_mem, get_system_io(),
> -                                     0x28, 32, TYPE_PCI_BUS);
> +                                     PCI_DEVFN(5, 0), 32, TYPE_PCI_BUS);
>
>      for (size_t i = 0; i < 3; i++) {
>          char *name = g_strdup_printf("pci.lomem%zu", i);
> --
> 2.26.2
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]