[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL v2 28/65] failover: Remove memory leak
From: |
Michael S. Tsirkin |
Subject: |
[PULL v2 28/65] failover: Remove memory leak |
Date: |
Wed, 9 Dec 2020 13:08:48 -0500 |
From: Juan Quintela <quintela@redhat.com>
Two things, at this point:
* n->primary_device_id has to be set, otherwise
virtio_net_find_primary don't work. So we have a leak here.
* it has to be exactly the same that prim_dev->id because what
qdev_find_recursive() does is just compare this two values.
So remove the unneeded assignment and leaky bits.
Signed-off-by: Juan Quintela <quintela@redhat.com>
Message-Id: <20201118083748.1328-14-quintela@redhat.com>
Reviewed-by: Michael S. Tsirkin <mst@redhat.com>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
hw/net/virtio-net.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/hw/net/virtio-net.c b/hw/net/virtio-net.c
index 6e5a56a230..70fa372c08 100644
--- a/hw/net/virtio-net.c
+++ b/hw/net/virtio-net.c
@@ -854,9 +854,7 @@ static DeviceState
*virtio_connect_failover_devices(VirtIONet *n, Error **errp)
Error *err = NULL;
prim_dev = virtio_net_find_primary(n, &err);
- if (prim_dev) {
- n->primary_device_id = g_strdup(prim_dev->id);
- } else {
+ if (!prim_dev) {
error_propagate(errp, err);
}
--
MST
- [PULL v2 15/65] unit-test: Add testcase for pxb, (continued)
- [PULL v2 15/65] unit-test: Add testcase for pxb, Michael S. Tsirkin, 2020/12/09
- [PULL v2 20/65] failover: Remove unused parameter, Michael S. Tsirkin, 2020/12/09
- [PULL v2 19/65] failover: primary bus is only used once, and where it is set, Michael S. Tsirkin, 2020/12/09
- [PULL v2 22/65] failover: qdev_device_add() returns err or dev set, Michael S. Tsirkin, 2020/12/09
- [PULL v2 21/65] failover: Remove external partially_hotplugged property, Michael S. Tsirkin, 2020/12/09
- [PULL v2 23/65] failover: Rename bool to failover_primary_hidden, Michael S. Tsirkin, 2020/12/09
- [PULL v2 24/65] failover: g_strcmp0() knows how to handle NULL, Michael S. Tsirkin, 2020/12/09
- [PULL v2 25/65] failover: Remove primary_device_opts, Michael S. Tsirkin, 2020/12/09
- [PULL v2 26/65] failover: remove standby_id variable, Michael S. Tsirkin, 2020/12/09
- [PULL v2 27/65] failover: Remove primary_device_dict, Michael S. Tsirkin, 2020/12/09
- [PULL v2 28/65] failover: Remove memory leak,
Michael S. Tsirkin <=
- [PULL v2 29/65] failover: simplify virtio_net_find_primary(), Michael S. Tsirkin, 2020/12/09
- [PULL v2 30/65] failover: should_be_hidden() should take a bool, Michael S. Tsirkin, 2020/12/09
- [PULL v2 31/65] failover: Rename function to hide_device(), Michael S. Tsirkin, 2020/12/09
- [PULL v2 32/65] failover: virtio_net_connect_failover_devices() does nothing, Michael S. Tsirkin, 2020/12/09
- [PULL v2 33/65] failover: Rename to failover_find_primary_device(), Michael S. Tsirkin, 2020/12/09
- [PULL v2 34/65] failover: simplify qdev_device_add() failover case, Michael S. Tsirkin, 2020/12/09
- [PULL v2 35/65] failover: simplify qdev_device_add(), Michael S. Tsirkin, 2020/12/09
- [PULL v2 36/65] failover: make sure that id always exist, Michael S. Tsirkin, 2020/12/09
- [PULL v2 38/65] failover: split failover_find_primary_device_id(), Michael S. Tsirkin, 2020/12/09
- [PULL v2 39/65] failover: We don't need to cache primary_device_id anymore, Michael S. Tsirkin, 2020/12/09