[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [RFC v6 07/11] i386: move TCG cpu class initialization out of helper

From: Claudio Fontana
Subject: Re: [RFC v6 07/11] i386: move TCG cpu class initialization out of helper.c
Date: Sun, 29 Nov 2020 12:53:09 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.12.0

On 11/27/20 9:43 PM, Eduardo Habkost wrote:
> On Fri, Nov 27, 2020 at 08:47:00PM +0100, Claudio Fontana wrote:
>> On 11/27/20 8:04 PM, Eduardo Habkost wrote:
> [...]
>>> Maybe we should rename CPUClass.synchronize_from_tb to
>>> CPUClass.tcg_synchronize_from_tb?  Maybe we should have a
>> possibly, yes.
>>> separate TCGCpuOperations struct to carry TCG-specific methods?
>> interesting, will think about it.
> I'm working on it at:
> https://gitlab.com/ehabkost/qemu/-/commits/work/tcg-cpu-ops
> Feel free to reuse it, if you want to do it before your series.
> Otherwise, I can rebase it after your series is merged.
> I didn't touch do_interrupt(), because of the aarch64 weirdness.


yes it makes sense to separate more clearly I think what is tcg only among 
those operations,

it is a bit tangent to my series in the sense that those methods need to be set 
one way or another,
either in cc-> or in cc->tcg_ops,

but yes, we could put those changes before or after the series, and I think 
they make sense.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]