[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1799919] Re: IDE HDD emulation random read/write errors

From: Peter Maydell
Subject: [Bug 1799919] Re: IDE HDD emulation random read/write errors
Date: Fri, 13 Nov 2020 16:30:39 -0000

I tried the repro case five times and each time it ran OK to the point
of asking for floppy 2. So that suggests we probably fixed whatever it

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  IDE HDD emulation random read/write errors

Status in QEMU:

Bug description:
  I unfortunately can’t give more tracks other than how to reproduce the
  bug, especially that the bug occurs randomly.

  Basically, I’m trying to install DOS 6.22 on an emulated ISA machine,
  and it fails, DOS complaining about read or write error on drive C.
  Repeating the operation multiple time, I see it occurs at random
  stage, sometime even before it partitions the drive, sometime when it
  formats the drive, sometime when it copies the files from the floppy
  to the drive.

  To test it, unpack the attached archive and execute `./run` from the
  extracted directory. The archive contains three raw floppy images for
  installing DOS 6.22, and a Bourne Shell script which invokes QEmu.
  Just press enter at any installation stage, the bug may occurs at any

  I tried with `cache=none` to be sure it’s not a cache issue, but its
  the same whatever the cache policy is.

  Version and environment: using QEmu 3.0 on Ubuntu 16.04 on a 32 bits
  DELL Inspiron 9400 (not an emulation, that’s my real laptop).

  For why I’m using QEmu for this: the installation proceeds with not
  error in VirtualBox, but I wanted to use QEmu to have a serial mouse
  which is not available with QEmu and to have finer control over the
  machine configuration ; VirtualBox although good, is more limited in
  that regard.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]