[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1674056] Re: USB keyboard and mouse sucked into qemu-kvm (somewhere

From: Thomas Huth
Subject: [Bug 1674056] Re: USB keyboard and mouse sucked into qemu-kvm (somewhere)
Date: Tue, 10 Nov 2020 14:57:20 -0000

The QEMU project is currently considering to move its bug tracking to another 
system. For this we need to know which bugs are still valid and which could be 
closed already. Thus we are setting older bugs to "Incomplete" now.
If you still think this bug report here is valid, then please switch the state 
back to "New" within the next 60 days, otherwise this report will be marked as 
"Expired". Or mark it as "Fix Released" if the problem has been solved with a 
newer version of QEMU already. Thank you and sorry for the inconvenience.

** Changed in: qemu
       Status: New => Incomplete

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  USB keyboard and mouse sucked into qemu-kvm (somewhere)

Status in QEMU:

Bug description:
  i am unable to run a command line qemu that does not "suck in" the keyboard 
and mouse of the host PC
  i tried all that i could from the command line parameters i want to run a 
headless gui-less kvm host

  if i specify a second set of keyboard and mouse with the -usb the only thing 
that is diffrent is that i have a keyboard and mouse in the VM if i specify the 
host keyboard and mouse same thing ... the vm is working fine but the host has 
no control , no keyboard. i dont see any output of anything 
  the only recourse i have is ctrl+alt+delete  and that resets the host after 
2-3 times. 

  i tried ctrl+alt, ctrl+alt+x , c , z , 2 , etc... also alt + all those 
combination and alt with F keys 
  no luck. 

  my command line looks like this (altough i tried many other variations)
  qemu-system-x86_64 -M q35 -enable-kvm \
  -cpu host,kvm=off -m 4096 -smp cpu=4,sockets=1,cores=4,treads=1 \
  -drive file=xyz.qcow2,if=scsi \
  -device vfio-pci, ... (GPU) \
  -device vfio-pci, .... (GPU audio) \
  -usb -usbdevice host:XXXX:XXXX -usbdevice host:XXXX:XXXX \   <<< same 
behaviour with and without
  -vga none -vnc localhost:1 -daemonize  

  i tried with -nographics , -curses, -monitor stdio, pty and none, same result 
and with -serial as well
  tried </dev/null at the end of the command no luck same with & 

  my guess is that the keyboard and mouse gets grabbed by the "window"
  of the qemu regardless if there is graphics or not and i have not foud
  a "-headless" ,"-nograb" or "-nopussygrab" mode . (yeah had to make
  the joke :P)

  Intel(R) Core(TM) i5-4690K CPU @ 3.50GHz
  ram > 8Gb
  keyboard is logitech
  mouse is logitech

  distro is suse leap 42.1 (made with suseStudio)

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]