[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 33/33] virtio-vga: Use typedef name for instance_size
From: |
Eduardo Habkost |
Subject: |
[PULL 33/33] virtio-vga: Use typedef name for instance_size |
Date: |
Thu, 10 Sep 2020 14:21:12 -0400 |
This makes the code consistent with the rest of QOM code in QEMU,
and will make automated conversion to type declaration macros
simpler.
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
Reviewed-by: Gerd Hoffmann <kraxel@redhat.com>
Message-Id: <20200824215936.2961951-7-ehabkost@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
hw/display/virtio-vga.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/hw/display/virtio-vga.c b/hw/display/virtio-vga.c
index 17e5658d43..573e7d5928 100644
--- a/hw/display/virtio-vga.c
+++ b/hw/display/virtio-vga.c
@@ -195,8 +195,8 @@ static void virtio_vga_base_class_init(ObjectClass *klass,
void *data)
static TypeInfo virtio_vga_base_info = {
.name = TYPE_VIRTIO_VGA_BASE,
.parent = TYPE_VIRTIO_PCI,
- .instance_size = sizeof(struct VirtIOVGABase),
- .class_size = sizeof(struct VirtIOVGABaseClass),
+ .instance_size = sizeof(VirtIOVGABase),
+ .class_size = sizeof(VirtIOVGABaseClass),
.class_init = virtio_vga_base_class_init,
.abstract = true,
};
@@ -226,7 +226,7 @@ static void virtio_vga_inst_initfn(Object *obj)
static VirtioPCIDeviceTypeInfo virtio_vga_info = {
.generic_name = TYPE_VIRTIO_VGA,
.parent = TYPE_VIRTIO_VGA_BASE,
- .instance_size = sizeof(struct VirtIOVGA),
+ .instance_size = sizeof(VirtIOVGA),
.instance_init = virtio_vga_inst_initfn,
};
--
2.26.2
- [PULL 10/33] Use DECLARE_*CHECKER* macros, (continued)
- [PULL 10/33] Use DECLARE_*CHECKER* macros, Eduardo Habkost, 2020/09/10
- [PULL 23/33] sabre: Rename SABRE_DEVICE to SABRE, Eduardo Habkost, 2020/09/10
- [PULL 24/33] usb: Rename USB_SERIAL_DEV to USB_SERIAL, Eduardo Habkost, 2020/09/10
- [PULL 22/33] rs6000_mc: Rename RS6000MC_DEVICE to RS6000MC, Eduardo Habkost, 2020/09/10
- [PULL 28/33] xilinx_axidma: Use typedef name for instance_size, Eduardo Habkost, 2020/09/10
- [PULL 29/33] omap_intc: Use typedef name for instance_size, Eduardo Habkost, 2020/09/10
- [PULL 25/33] vfio: Rename PCI_VFIO to VFIO_PCI, Eduardo Habkost, 2020/09/10
- [PULL 31/33] xilinx_axienet: Use typedef name for instance_size, Eduardo Habkost, 2020/09/10
- [PULL 30/33] lpc_ich9: Use typedef name for instance_size, Eduardo Habkost, 2020/09/10
- [PULL 26/33] pc87312: Rename TYPE_PC87312_SUPERIO to TYPE_PC87312, Eduardo Habkost, 2020/09/10
- [PULL 33/33] virtio-vga: Use typedef name for instance_size,
Eduardo Habkost <=
- [PULL 32/33] vhost-user-vga: Use typedef name for instance_size, Eduardo Habkost, 2020/09/10
- [PULL 09/33] Move QOM typedefs and add missing includes, Eduardo Habkost, 2020/09/10
- Re: [PULL 00/33] QOM boilerplate cleanup (v4), Peter Maydell, 2020/09/11