[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 08/33] Delete duplicate QOM typedefs
From: |
Eduardo Habkost |
Subject: |
[PULL 08/33] Delete duplicate QOM typedefs |
Date: |
Thu, 10 Sep 2020 14:20:47 -0400 |
Generated using:
$ ./scripts/codeconverter/converter.py -i \
--pattern=QOMDuplicatedTypedefs $(git grep -l '' -- '*.[ch]')
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
Message-Id: <20200831210740.126168-8-ehabkost@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
include/crypto/secret_keyring.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/crypto/secret_keyring.h b/include/crypto/secret_keyring.h
index 9f371ad251..4345eb048e 100644
--- a/include/crypto/secret_keyring.h
+++ b/include/crypto/secret_keyring.h
@@ -39,14 +39,14 @@
typedef struct QCryptoSecretKeyring QCryptoSecretKeyring;
typedef struct QCryptoSecretKeyringClass QCryptoSecretKeyringClass;
-typedef struct QCryptoSecretKeyring {
+struct QCryptoSecretKeyring {
QCryptoSecretCommon parent;
int32_t serial;
-} QCryptoSecretKeyring;
+};
-typedef struct QCryptoSecretKeyringClass {
+struct QCryptoSecretKeyringClass {
QCryptoSecretCommonClass parent;
-} QCryptoSecretKeyringClass;
+};
#endif /* QCRYPTO_SECRET_KEYRING_H */
--
2.26.2
- [PULL 00/33] QOM boilerplate cleanup (v4), Eduardo Habkost, 2020/09/10
- [PULL 02/33] qom: make object_ref/unref use a void * instead of Object *., Eduardo Habkost, 2020/09/10
- [PULL 03/33] qom: provide convenient macros for declaring and defining types, Eduardo Habkost, 2020/09/10
- [PULL 05/33] qom: DECLARE_*_CHECKERS macros, Eduardo Habkost, 2020/09/10
- [PULL 06/33] qom: Make type checker functions accept const pointers, Eduardo Habkost, 2020/09/10
- [PULL 01/33] memory: Remove kernel-doc comment marker, Eduardo Habkost, 2020/09/10
- [PULL 04/33] qom: Allow class type name to be specified in OBJECT_DECLARE*, Eduardo Habkost, 2020/09/10
- [PULL 08/33] Delete duplicate QOM typedefs,
Eduardo Habkost <=
- [PULL 12/33] Use OBJECT_DECLARE_TYPE where possible, Eduardo Habkost, 2020/09/10
- [PULL 11/33] Use DECLARE_*CHECKER* when possible (--force mode), Eduardo Habkost, 2020/09/10
- [PULL 14/33] gpex: Fix type checking function name, Eduardo Habkost, 2020/09/10
- [PULL 13/33] Use OBJECT_DECLARE_SIMPLE_TYPE when possible, Eduardo Habkost, 2020/09/10
- [PULL 07/33] codeconverter: script for automating QOM code cleanups, Eduardo Habkost, 2020/09/10
- [PULL 15/33] ap-device: Rename AP_DEVICE_TYPE to TYPE_AP_DEVICE, Eduardo Habkost, 2020/09/10
- [PULL 17/33] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE, Eduardo Habkost, 2020/09/10
- [PULL 16/33] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB_CCID_DEV, Eduardo Habkost, 2020/09/10
- [PULL 19/33] ahci: Rename ICH_AHCI to ICH9_AHCI, Eduardo Habkost, 2020/09/10
- [PULL 18/33] vmgenid: Rename VMGENID_DEVICE to TYPE_VMGENID, Eduardo Habkost, 2020/09/10