[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 19/27] ahci: Rename ICH_AHCI to ICH9_AHCI
From: |
Eduardo Habkost |
Subject: |
[PULL 19/27] ahci: Rename ICH_AHCI to ICH9_AHCI |
Date: |
Thu, 3 Sep 2020 16:52:39 -0400 |
Make the type checking macro name consistent with the TYPE_*
constant.
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
Message-Id: <20200902224311.1321159-33-ehabkost@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
include/hw/ide/ahci.h | 2 +-
hw/ide/ahci.c | 4 ++--
hw/ide/ich.c | 8 ++++----
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/include/hw/ide/ahci.h b/include/hw/ide/ahci.h
index 4cf6813d80..da3cddcc65 100644
--- a/include/hw/ide/ahci.h
+++ b/include/hw/ide/ahci.h
@@ -54,7 +54,7 @@ typedef struct AHCIState {
typedef struct AHCIPCIState AHCIPCIState;
#define TYPE_ICH9_AHCI "ich9-ahci"
-DECLARE_INSTANCE_CHECKER(AHCIPCIState, ICH_AHCI,
+DECLARE_INSTANCE_CHECKER(AHCIPCIState, ICH9_AHCI,
TYPE_ICH9_AHCI)
int32_t ahci_get_num_ports(PCIDevice *dev);
diff --git a/hw/ide/ahci.c b/hw/ide/ahci.c
index b696c6291a..ee1d47ff75 100644
--- a/hw/ide/ahci.c
+++ b/hw/ide/ahci.c
@@ -1819,7 +1819,7 @@ type_init(sysbus_ahci_register_types)
int32_t ahci_get_num_ports(PCIDevice *dev)
{
- AHCIPCIState *d = ICH_AHCI(dev);
+ AHCIPCIState *d = ICH9_AHCI(dev);
AHCIState *ahci = &d->ahci;
return ahci->ports;
@@ -1827,7 +1827,7 @@ int32_t ahci_get_num_ports(PCIDevice *dev)
void ahci_ide_create_devs(PCIDevice *dev, DriveInfo **hd)
{
- AHCIPCIState *d = ICH_AHCI(dev);
+ AHCIPCIState *d = ICH9_AHCI(dev);
AHCIState *ahci = &d->ahci;
int i;
diff --git a/hw/ide/ich.c b/hw/ide/ich.c
index eff3188fff..51cd2f38b7 100644
--- a/hw/ide/ich.c
+++ b/hw/ide/ich.c
@@ -91,14 +91,14 @@ static const VMStateDescription vmstate_ich9_ahci = {
static void pci_ich9_reset(DeviceState *dev)
{
- AHCIPCIState *d = ICH_AHCI(dev);
+ AHCIPCIState *d = ICH9_AHCI(dev);
ahci_reset(&d->ahci);
}
static void pci_ich9_ahci_init(Object *obj)
{
- struct AHCIPCIState *d = ICH_AHCI(obj);
+ struct AHCIPCIState *d = ICH9_AHCI(obj);
ahci_init(&d->ahci, DEVICE(obj));
}
@@ -108,7 +108,7 @@ static void pci_ich9_ahci_realize(PCIDevice *dev, Error
**errp)
struct AHCIPCIState *d;
int sata_cap_offset;
uint8_t *sata_cap;
- d = ICH_AHCI(dev);
+ d = ICH9_AHCI(dev);
int ret;
ahci_realize(&d->ahci, DEVICE(dev), pci_get_address_space(dev), 6);
@@ -154,7 +154,7 @@ static void pci_ich9_ahci_realize(PCIDevice *dev, Error
**errp)
static void pci_ich9_uninit(PCIDevice *dev)
{
struct AHCIPCIState *d;
- d = ICH_AHCI(dev);
+ d = ICH9_AHCI(dev);
msi_uninit(dev);
ahci_uninit(&d->ahci);
--
2.26.2
- [PULL 12/27] Use OBJECT_DECLARE_SIMPLE_TYPE when possible, (continued)
- [PULL 12/27] Use OBJECT_DECLARE_SIMPLE_TYPE when possible, Eduardo Habkost, 2020/09/03
- [PULL 13/27] gpex: Fix type checking function name, Eduardo Habkost, 2020/09/03
- [PULL 09/27] Use DECLARE_*CHECKER* macros, Eduardo Habkost, 2020/09/03
- [PULL 16/27] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB_CCID_DEV, Eduardo Habkost, 2020/09/03
- [PULL 14/27] chardev: Rename TYPE_CHARDEV_* to TYPE_*_CHARDEV, Eduardo Habkost, 2020/09/03
- [PULL 11/27] Use OBJECT_DECLARE_TYPE where possible, Eduardo Habkost, 2020/09/03
- [PULL 18/27] vmgenid: Rename VMGENID_DEVICE to TYPE_VMGENID, Eduardo Habkost, 2020/09/03
- [PULL 21/27] filter-rewriter: Rename FILTER_COLO_REWRITER to FILTER_REWRITER, Eduardo Habkost, 2020/09/03
- [PULL 24/27] usb: Rename USB_SERIAL_DEV to USB_SERIAL, Eduardo Habkost, 2020/09/03
- [PULL 26/27] pc87312: Rename TYPE_PC87312_SUPERIO to TYPE_PC87312, Eduardo Habkost, 2020/09/03
- [PULL 19/27] ahci: Rename ICH_AHCI to ICH9_AHCI,
Eduardo Habkost <=
- [PULL 15/27] ap-device: Rename AP_DEVICE_TYPE to TYPE_AP_DEVICE, Eduardo Habkost, 2020/09/03
- [PULL 17/27] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE, Eduardo Habkost, 2020/09/03
- [PULL 20/27] esp: Rename ESP_STATE to ESP, Eduardo Habkost, 2020/09/03
- [PULL 22/27] rs6000_mc: Rename RS6000MC_DEVICE to RS6000MC, Eduardo Habkost, 2020/09/03
- [PULL 27/27] tusb6010: Rename TUSB to TUSB6010, Eduardo Habkost, 2020/09/03
- [PULL 23/27] sabre: Rename SABRE_DEVICE to SABRE, Eduardo Habkost, 2020/09/03
- [PULL 25/27] vfio: Rename PCI_VFIO to VFIO_PCI, Eduardo Habkost, 2020/09/03
- [PULL 08/27] Move QOM typedefs and add missing includes, Eduardo Habkost, 2020/09/03
- Re: [PULL 00/27] QOM boilerplate cleanup, Peter Maydell, 2020/09/05