[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 58/63] hvf: Rename HVF_STATE to HVF_ACCEL
From: |
Eduardo Habkost |
Subject: |
[PATCH 58/63] hvf: Rename HVF_STATE to HVF_ACCEL |
Date: |
Wed, 2 Sep 2020 18:43:06 -0400 |
Make the type checking macro name consistent with the TYPE_*
constant.
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Cameron Esfahani <dirty@apple.com>
Cc: Roman Bolshakov <r.bolshakov@yadro.com>
Cc: qemu-devel@nongnu.org
---
include/sysemu/hvf.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/sysemu/hvf.h b/include/sysemu/hvf.h
index 1398679458..195795e857 100644
--- a/include/sysemu/hvf.h
+++ b/include/sysemu/hvf.h
@@ -37,7 +37,7 @@ void hvf_vcpu_destroy(CPUState *);
#define TYPE_HVF_ACCEL ACCEL_CLASS_NAME("hvf")
typedef struct HVFState HVFState;
-DECLARE_INSTANCE_CHECKER(HVFState, HVF_STATE,
+DECLARE_INSTANCE_CHECKER(HVFState, HVF_ACCEL,
TYPE_HVF_ACCEL)
#endif
--
2.26.2
- Re: [PATCH 50/63] tpm_crb: Rename CRB to TPM_CRB, (continued)
- [PATCH 52/63] usb: Rename USB_REDIRECT to USB_REDIR, Eduardo Habkost, 2020/09/02
- [PATCH 51/63] tpm_spapr: Rename VIO_SPAPR_VTPM to TPM_SPAPR, Eduardo Habkost, 2020/09/02
- [PATCH 53/63] usb: Rename USB_SERIAL_DEV to USB_SERIAL, Eduardo Habkost, 2020/09/02
- [PATCH 54/63] usb: Rename USB_STORAGE_DEV to USB_STORAGE, Eduardo Habkost, 2020/09/02
- [PATCH 56/63] vmxnet3: Rename VMXNET3_DEVICE* to VMXNET3*, Eduardo Habkost, 2020/09/02
- [PATCH 55/63] vfio: Rename PCI_VFIO to VFIO_PCI, Eduardo Habkost, 2020/09/02
- [PATCH 58/63] hvf: Rename HVF_STATE to HVF_ACCEL,
Eduardo Habkost <=
- [PATCH 57/63] xen: Rename XENBACKEND_DEVICE to XENBACKEND, Eduardo Habkost, 2020/09/02
- [PATCH 60/63] tcg: Rename TCG_STATE to TCG_ACCEL, Eduardo Habkost, 2020/09/02
- [PATCH 61/63] tests: Rename TYPE_DUMMY to TYPE_DUMMY_OBJECT, Eduardo Habkost, 2020/09/02
- [PATCH 62/63] tests: Rename DYNAMIC_TYPE to DYNAMIC_PROPS, Eduardo Habkost, 2020/09/02
- [PATCH 63/63] tests: Rename STATIC_TYPE to STATIC_PROPS, Eduardo Habkost, 2020/09/02
- [PATCH 59/63] kvm: Rename KVM_STATE to KVM_ACCEL, Eduardo Habkost, 2020/09/02
- Re: [PATCH 00/63] qom: Rename macros for consistency, Eduardo Habkost, 2020/09/03