[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 08/63] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE
From: |
Eduardo Habkost |
Subject: |
[PATCH 08/63] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE |
Date: |
Wed, 2 Sep 2020 18:42:16 -0400 |
This will make the type name constant consistent with the name of
the type checking macro.
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Cornelia Huck <cohuck@redhat.com>
Cc: Thomas Huth <thuth@redhat.com>
Cc: Christian Borntraeger <borntraeger@de.ibm.com>
Cc: Tony Krowiak <akrowiak@linux.ibm.com>
Cc: Halil Pasic <pasic@linux.ibm.com>
Cc: Pierre Morel <pmorel@linux.ibm.com>
Cc: Alex Williamson <alex.williamson@redhat.com>
Cc: qemu-s390x@nongnu.org
Cc: qemu-devel@nongnu.org
---
hw/vfio/ap.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/hw/vfio/ap.c b/hw/vfio/ap.c
index 68ed059b39..582c091a24 100644
--- a/hw/vfio/ap.c
+++ b/hw/vfio/ap.c
@@ -30,7 +30,7 @@
#include "exec/address-spaces.h"
#include "qom/object.h"
-#define VFIO_AP_DEVICE_TYPE "vfio-ap"
+#define TYPE_VFIO_AP_DEVICE "vfio-ap"
struct VFIOAPDevice {
APDevice apdev;
@@ -39,7 +39,7 @@ struct VFIOAPDevice {
typedef struct VFIOAPDevice VFIOAPDevice;
DECLARE_INSTANCE_CHECKER(VFIOAPDevice, VFIO_AP_DEVICE,
- VFIO_AP_DEVICE_TYPE)
+ TYPE_VFIO_AP_DEVICE)
static void vfio_ap_compute_needs_reset(VFIODevice *vdev)
{
@@ -72,7 +72,7 @@ static VFIOGroup *vfio_ap_get_group(VFIOAPDevice *vapdev,
Error **errp)
if (!group_path) {
error_setg(errp, "%s: no iommu_group found for %s: %s",
- VFIO_AP_DEVICE_TYPE, vapdev->vdev.sysfsdev,
gerror->message);
+ TYPE_VFIO_AP_DEVICE, vapdev->vdev.sysfsdev,
gerror->message);
g_error_free(gerror);
return NULL;
}
@@ -176,7 +176,7 @@ static void vfio_ap_class_init(ObjectClass *klass, void
*data)
}
static const TypeInfo vfio_ap_info = {
- .name = VFIO_AP_DEVICE_TYPE,
+ .name = TYPE_VFIO_AP_DEVICE,
.parent = TYPE_AP_DEVICE,
.instance_size = sizeof(VFIOAPDevice),
.class_init = vfio_ap_class_init,
--
2.26.2
- Re: [PATCH 01/63] gpex: Fix type checking function name, (continued)
- [PATCH 03/63] chardev: Rename TYPE_BRAILLE_CHARDEV to TYPE_BAUM_CHARDEV, Eduardo Habkost, 2020/09/02
- [PATCH 02/63] chardev: Rename TYPE_CHARDEV_* to TYPE_*_CHARDEV, Eduardo Habkost, 2020/09/02
- [PATCH 04/63] chardev: Rename TYPE_MSMOUSE_CHARDEV to TYPE_MOUSE_CHARDEV, Eduardo Habkost, 2020/09/02
- [PATCH 05/63] ap-device: Rename AP_DEVICE_TYPE to TYPE_AP_DEVICE, Eduardo Habkost, 2020/09/02
- [PATCH 07/63] rdma: Rename PVRDMA_HW_NAME to TYPE_PVRDMA_DEV, Eduardo Habkost, 2020/09/02
- [PATCH 08/63] vfio: Rename VFIO_AP_DEVICE_TYPE to TYPE_VFIO_AP_DEVICE,
Eduardo Habkost <=
- [PATCH 09/63] vmcoreinfo: Rename VMCOREINFO_DEVICE to TYPE_VMCOREINFO, Eduardo Habkost, 2020/09/02
- [PATCH 06/63] dev-smartcard-reader: Rename CCID_DEV_NAME to TYPE_USB_CCID_DEV, Eduardo Habkost, 2020/09/02
- [PATCH 10/63] vmgenid: Rename VMGENID_DEVICE to TYPE_VMGENID, Eduardo Habkost, 2020/09/02
- [PATCH 11/63] edu: Rename TYPE_PCI_EDU_DEVICE to TYPE_EDU, Eduardo Habkost, 2020/09/02
- [PATCH 12/63] etrax: Rename TYPE_ETRAX_FS_SERIAL to TYPE_ETRAX_SERIAL, Eduardo Habkost, 2020/09/02
- [PATCH 13/63] etrax: Rename TYPE_ETRAX_FS_TIMER to TYPE_ETRAX_TIMER, Eduardo Habkost, 2020/09/02