qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 1/2] checkpatch: Rename top_of_kernel_tree() to top_of_qemu_tree(


From: Aleksandar Markovic
Subject: [PATCH 1/2] checkpatch: Rename top_of_kernel_tree() to top_of_qemu_tree()
Date: Sat, 20 Jun 2020 15:32:06 +0200

This subroutine establishes top of qemu, not kernel, tree.

Do appropriate renaming.

Signed-off-by: Aleksandar Markovic <aleksandar.qemu.devel@gmail.com>
---
 scripts/checkpatch.pl | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 0ba213e9f2..c760c5a4a9 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -190,14 +190,14 @@ if ($terse) {
 
 if ($tree) {
        if (defined $root) {
-               if (!top_of_kernel_tree($root)) {
+               if (!top_of_qemu_tree($root)) {
                        die "$P: $root: --root does not point at a valid 
tree\n";
                }
        } else {
-               if (top_of_kernel_tree('.')) {
+               if (top_of_qemu_tree('.')) {
                        $root = '.';
                } elsif ($0 =~ m@(.*)/scripts/[^/]*$@ &&
-                                               top_of_kernel_tree($1)) {
+                                               top_of_qemu_tree($1)) {
                        $root = $1;
                }
        }
@@ -456,7 +456,7 @@ if ($chk_branch) {
 
 exit($exit);
 
-sub top_of_kernel_tree {
+sub top_of_qemu_tree {
        my ($root) = @_;
 
        my @tree_check = (
-- 
2.20.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]