qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH v3 03/12] hw/tpm: Rename TPMDEV as TPM_BACKEND in Kconfig


From: Philippe Mathieu-Daudé
Subject: [PATCH v3 03/12] hw/tpm: Rename TPMDEV as TPM_BACKEND in Kconfig
Date: Fri, 12 Jun 2020 10:54:35 +0200

The TPMDEV describe TPM backends. Use the TPM_BACKEND config
name which is self-explicit.

Reviewed-by: Stefan Berger <stefanb@linux.ibm.com>
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com>
---
 hw/tpm/Kconfig | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/hw/tpm/Kconfig b/hw/tpm/Kconfig
index 4794e7fe28..5028fd8880 100644
--- a/hw/tpm/Kconfig
+++ b/hw/tpm/Kconfig
@@ -1,4 +1,4 @@
-config TPMDEV
+config TPM_BACKEND
     bool
     depends on TPM
 
@@ -15,26 +15,26 @@ config TPM_TIS_SYSBUS
 config TPM_TIS
     bool
     depends on TPM
-    select TPMDEV
+    select TPM_BACKEND
 
 config TPM_CRB
     bool
     depends on TPM && PC
-    select TPMDEV
+    select TPM_BACKEND
 
 config TPM_PASSTHROUGH
     bool
     default y
     # FIXME: should check for x86 host as well
-    depends on TPMDEV && LINUX
+    depends on TPM_BACKEND && LINUX
 
 config TPM_EMULATOR
     bool
     default y
-    depends on TPMDEV
+    depends on TPM_BACKEND
 
 config TPM_SPAPR
     bool
     default y
     depends on TPM && PSERIES
-    select TPMDEV
+    select TPM_BACKEND
-- 
2.21.3




reply via email to

[Prev in Thread] Current Thread [Next in Thread]