[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1859989] Re: qemu-img has broken output with large snapshot names

From: pevogam
Subject: [Bug 1859989] Re: qemu-img has broken output with large snapshot names
Date: Fri, 17 Jan 2020 10:42:13 -0000

Hi Max,

It last worked in (previous version we used):
[root@c15 ~]# qemu-img --version
qemu-img version 3.1.1 (qemu-3.1.1-2.fc30)
Copyright (c) 2003-2018 Fabrice Bellard and the QEMU Project developers

Yes, unfortunately Launchpad doesn't seem to support any literal
formatting which is why I tried to use the ``` to signal this. I will
attach some images from both version to counter this effect and make it
clearer to you where the problem is which is indeed in the clash between
the state name and the size. The IEC prefixes were something new and we
could handle that but not the lack of space which is new in this version
we tried.

** Attachment added: "qemu.png"

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  qemu-img has broken output with large snapshot names

Status in QEMU:

Bug description:
  On Qemu 4.1.1 the output of snapshots breaks if the chosen state name
  is too long:

  # qemu-img snapshot -l /mnt/local/some_image.qcow2
  Snapshot list:
  ID        TAG                 VM SIZE                DATE       VM CLOCK
  1         online_provider_with_dhcp747 MiB 2020-01-15 12:05:01   00:00:45.873

  Prior to 4.1.1 this used to work with extra tabs for the VM SIZE
  values. The collision is also disabling us from using a regex on top
  of this output to detect the snapshot.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]