[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1856834] Re: Virtio broken in qemu ppc in 4.2.0 and other versions

From: ecsdn
Subject: [Bug 1856834] Re: Virtio broken in qemu ppc in 4.2.0 and other versions
Date: Tue, 07 Jan 2020 18:01:24 -0000

With some precautionary measures I think I can provide it. Not sure what
of our drivers may already be compiled in etc so I need to send it to
you privately so only you have access for testing etc after which you
would delete it once issue fixed or discovered etc. Is it possible to
send you private message on here with such a link or better email?

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  Virtio broken in qemu ppc in 4.2.0 and other versions

Status in QEMU:

Bug description:
  The same qemu -M mpc... command that works on qemu-system-ppc version
  2.8.0 freezes guest on bootup and shows error for qemu-system-ppc
  version 4.2.0release and 4.19dirtygit:

  qemu-system-ppc: virtio-blk failed to set guest notifier (-24), ensure -accel 
kvm is set.
  qemu-system-ppc: virtio_bus_start_ioeventfd: failed. Fallback to userspace 

  ends/freezes at:
  nbd: registered device at major 43

  I'm using -drive file=/home/me/rawimage.dd,if=virtio and works fine in
  version 2.8.0 installed with apt-get install (Ubuntu 17.04) and also
  with 2.8.0 official release from git/github that I compiled/built
  myself. But both of the newer releases fail on the same exact machine
  same config.

  I also noticed that qemu-2.8.0 was fine with mtd but the newer ones I tried 
weren't, ie gave
  qemu-system-ppc: -drive if=mtd: machine type does not support 
  (but I removed -drive if=mtd since wasn't using it anyway)

  I also tried on windows but I think virtio doesn't work on windows
  hosts at all? On windows host it fails the same way, even version 2.12
  as well as 4.1.10...

  ./configure --prefix=/opt/... --enable-fdt --enable-kvm --enable-debug

  (basically all steps the same on same exact system same config, yet
  2.8.0 works fine whether apt-get installed or built from source while
  the others I built, 4.19/4.2.0 or 2.12/4.1.10(win) don't.)

  In case newer qemu versions act weird on various kernels, I did try with both 
vmlinuz-4.10.0-19-generic and vmlinuz-4.13.12-041312-generic (I didn't compile 
them but I can provide config-..files. This is on Ubuntu 17.04 x86_64 host 
emulating e500v2 cpm guest, ie -M mpc... GUEST kernel which is why I 
can't use -M ppce500 instead..)

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]