[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v4 10/40] target/arm: Rename ARMMMUIdx_S1NSE* to ARMMMUIdx_St

From: Richard Henderson
Subject: Re: [PATCH v4 10/40] target/arm: Rename ARMMMUIdx_S1NSE* to ARMMMUIdx_Stage1_E*
Date: Fri, 6 Dec 2019 10:20:22 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.2.1

On 12/6/19 7:47 AM, Peter Maydell wrote:
> On Tue, 3 Dec 2019 at 02:29, Richard Henderson
> <address@hidden> wrote:
>> This is part of a reorganization to the set of mmu_idx.
>> The EL1&0 regime is the only one that uses 2-stage translation.
>> Spelling out Stage avoids confusion with Secure.
> If you didn't delete the 'NS' from the name then it
> wouldn't be confusing...

It is not obvious to my eye how to break up S1NSE0 -- 'NS' is buried in the
middle.  It might be different if these names were architectural, as if the AT
names, but they're not.

I think it is clearer to reserve 'S' for 'Secure', and use it consistently.
E.g. not the current "S1E3" (stage 1 e3), but "SE3" (secure e3).

I think it is clearer to simply document that, unless "Stage" is present in the
name, the tlb contains the complete translation.  This makes "S12" redundant
off of "NSE0", and "S1" off of "E3".

We'll still need a renaming of with SecEL2, since "SE0" is no longer complete;
we will need to specify "Secure EL1&0" vs "Secure EL2&0".  Thus perhaps
"SEL10_0" to match the "EL10_0" name that I'm using in this series.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]