[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 1848556] Re: qemu-img check failing on remote image in Eoan

From: Launchpad Bug Tracker
Subject: [Bug 1848556] Re: qemu-img check failing on remote image in Eoan
Date: Mon, 02 Dec 2019 11:02:22 -0000

This bug was fixed in the package qemu - 1:4.0+dfsg-0ubuntu9.2

qemu (1:4.0+dfsg-0ubuntu9.2) eoan; urgency=medium

  * d/p/ubuntu/lp-1848556-curl-Handle-success-in-multi_check_completion.patch:
    fix a potential hang when qemu or qemu-img where accessing http backed
    disks via libcurl (LP: #1848556)
  * d/p/u/lp-1848497-virtio-balloon-fix-QEMU-4.0-config-size-migration-in.patch:
    fix migration issue from qemu <4.0 when using virtio-balloon (LP: #1848497)

 -- Christian Ehrhardt <address@hidden>  Mon, 21 Oct
2019 14:51:45 +0200

** Changed in: qemu (Ubuntu Eoan)
       Status: Fix Committed => Fix Released

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  qemu-img check failing on remote image in Eoan

Status in QEMU:
  Fix Released
Status in qemu package in Ubuntu:
  Fix Released
Status in qemu source package in Eoan:
  Fix Released
Status in qemu source package in Focal:
  Fix Released

Bug description:
  Ubuntu SRU Template:


   * There is fallout due to changes in libcurl that affect qemu and might 
     lead to a hang.

   * Fix by backporting the upstream fix

  [Test Case]

   * If you have network just run
     $ qemu-img check

   * Without network, install apache2, and get a complex qemu file (like a 
     cloud image) onto the system. Then access the file via apache http but 
     not localhost (that would work)

  [Regression Potential]

   * The change is local to the libcurl usage of qemu, so that could be 
     affected. But then this is what has been found to not work here, so I'd 
     expect not too much trouble. But if so then in the curl usage (which 
     means disks on http)

  [Other Info]
   * n/a


  The "qemu-img check" function is failing on remote (HTTP-hosted)
  images, beginning with Ubuntu 19.10 (qemu-utils version 1:4.0+dfsg-
  0ubuntu9). With previous versions, through Ubuntu 19.04/qemu-utils
  version 1:3.1+dfsg-2ubuntu3.5, the following worked:

  $ /usr/bin/qemu-img check
  No errors were found on the image.
  19778/36032 = 54.89% allocated, 90.34% fragmented, 89.90% compressed clusters
  Image end offset: 514064384

  The server holds an Apache server that hosts the cloud
  images on a LAN. Beginning with Ubuntu 19.10/qemu-utils 1:4.0+dfsg-
  0ubuntu9, the same command never returns. (I've left it for up to an
  hour with no change.) I'm able to wget the image from the same server
  and installation on which qemu-img check fails. I've tried several
  .img files on the server, ranging from Bionic to Eoan, with the same
  results with all of them.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]