qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PULL 01/19] util/hbitmap: strict hbitmap_reset


From: Eric Blake
Subject: Re: [PULL 01/19] util/hbitmap: strict hbitmap_reset
Date: Fri, 11 Oct 2019 16:48:22 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.1.0

On 10/11/19 4:25 PM, John Snow wrote:
From: Vladimir Sementsov-Ogievskiy <address@hidden>

hbitmap_reset has an unobvious property: it rounds requested region up.
It may provoke bugs, like in recently fixed write-blocking mode of
mirror: user calls reset on unaligned region, not keeping in mind that
there are possible unrelated dirty bytes, covered by rounded-up region
and information of this unrelated "dirtiness" will be lost.

Make hbitmap_reset strict: assert that arguments are aligned, allowing
only one exception when @start + @count == hb->orig_size. It's needed
to comfort users of hbitmap_next_dirty_area, which cares about
hb->orig_size.

Signed-off-by: Vladimir Sementsov-Ogievskiy <address@hidden>
Reviewed-by: Max Reitz <address@hidden>
Message-Id: <address@hidden>
[Maintainer edit: Max's suggestions from on-list. --js]
Signed-off-by: John Snow <address@hidden>
---
  include/qemu/hbitmap.h | 5 +++++
  tests/test-hbitmap.c   | 2 +-
  util/hbitmap.c         | 4 ++++
  3 files changed, 10 insertions(+), 1 deletion(-)


+++ b/util/hbitmap.c
@@ -476,6 +476,10 @@ void hbitmap_reset(HBitmap *hb, uint64_t start, uint64_t 
count)
      /* Compute range in the last layer.  */
      uint64_t first;
      uint64_t last = start + count - 1;
+    uint64_t gran = 1ULL << hb->granularity;
+
+    assert(!(start & (gran - 1)));
+    assert(!(count & (gran - 1)) || (start + count == hb->orig_size));

I know I'm replying a bit late (since this is now a pull request), but would it be worth using the dedicated macro:

assert(QEMU_IS_ALIGNED(start, gran));
assert(QEMU_IS_ALIGNED(count, gran) || start + count == hb->orig_size);

instead of open-coding it? (I would also drop the extra () around the right half of ||). If we want it, that would now be a followup patch.

--
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3226
Virtualization:  qemu.org | libvirt.org



reply via email to

[Prev in Thread] Current Thread [Next in Thread]