[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH-for-4.1 v4 1/7] virtio-balloon: Fix wrong sign e
From: |
Pankaj Gupta |
Subject: |
Re: [Qemu-devel] [PATCH-for-4.1 v4 1/7] virtio-balloon: Fix wrong sign extension of PFNs |
Date: |
Thu, 25 Jul 2019 08:36:54 -0400 (EDT) |
>
> If we directly cast from int to uint64_t, we will first sign-extend to
> an int64_t, which is wrong. We actually want to treat the PFNs like
> unsigned values.
>
> As far as I can see, this dates back to the initial virtio-balloon
> commit, but wasn't triggered as fairly big guests would be required.
>
> Cc: address@hidden
> Reported-by: Michael S. Tsirkin <address@hidden>
> Reviewed-by: David Gibson <address@hidden>
> Signed-off-by: David Hildenbrand <address@hidden>
> ---
> hw/virtio/virtio-balloon.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/hw/virtio/virtio-balloon.c b/hw/virtio/virtio-balloon.c
> index e85d1c0d5c..515abf6553 100644
> --- a/hw/virtio/virtio-balloon.c
> +++ b/hw/virtio/virtio-balloon.c
> @@ -343,8 +343,8 @@ static void virtio_balloon_handle_output(VirtIODevice
> *vdev, VirtQueue *vq)
> }
>
> while (iov_to_buf(elem->out_sg, elem->out_num, offset, &pfn, 4) ==
> 4) {
> + unsigned int p = virtio_ldl_p(vdev, &pfn);
> hwaddr pa;
> - int p = virtio_ldl_p(vdev, &pfn);
>
> pa = (hwaddr) p << VIRTIO_BALLOON_PFN_SHIFT;
> offset += 4;
> --
> 2.21.0
Reviewed-by: Pankaj Gupta <address@hidden>
>
>
>
- [Qemu-devel] [PATCH-for-4.1 v4 0/7] virtio-balloon: fixes, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 1/7] virtio-balloon: Fix wrong sign extension of PFNs, David Hildenbrand, 2019/07/25
- Re: [Qemu-devel] [PATCH-for-4.1 v4 1/7] virtio-balloon: Fix wrong sign extension of PFNs,
Pankaj Gupta <=
- [Qemu-devel] [PATCH-for-4.1 v4 2/7] virtio-balloon: Fix QEMU crashes on pagesize > BALLOON_PAGE_SIZE, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 3/7] virtio-balloon: Simplify deflate with pbp, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 4/7] virtio-balloon: Better names for offset variables in inflate/deflate code, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 5/7] virtio-balloon: Rework pbp tracking data, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 6/7] virtio-balloon: Use temporary PBP only, David Hildenbrand, 2019/07/25
- [Qemu-devel] [PATCH-for-4.1 v4 7/7] virtio-balloon: No need to track subpages for the PBP anymore, David Hildenbrand, 2019/07/25