[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1836501] Re: cpu_address_space_init fails with asserti

From: Peter Maydell
Subject: [Qemu-devel] [Bug 1836501] Re: cpu_address_space_init fails with assertion
Date: Thu, 18 Jul 2019 14:25:58 -0000

I can boot a KVM guest (either with the debian stretch qemu-system-arm
2.8.1, or with a head-of-upstream-git QEMU), which wouldn't work with
EL3 enabled, so I'm not sure what is going wrong for you. To try to
debug this further you'd need to build QEMU from source and start
running it under the debugger to see what exactly is going on and why
it's hitting that assertion.

I would be tempted to try a newer kernel to see if that helped. (My
working setup is using the debian stretch stock "4.9.0-0.bpo.9-armmp-
lpae #1 SMP Debian 4.9.168-1+deb9u3~deb8u1 (2019-06-17)", but in general
4.9 is fairly elderly now.)

For forums to talk about this kind of thing you might also try the qemu-
arm mailing list (https://lists.nongnu.org/mailman/listinfo/qemu-arm) or
qemu-devel itself (generally best to cc qemu-devel on qemu-arm emails
anyway, lots of people don't subscribe to the per-architecture lists).

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  cpu_address_space_init fails with assertion

Status in QEMU:

Bug description:
  qemu-system-arm does not start with version >= 2.6 and KVM enabled.

    cpu_address_space_init: Assertion `asidx == 0 || !kvm_enabled()'

  Hardware is Odroid XU4 with Exynos with 4.9.61+ Tested with Debian
  Stretch (9) or Buster (10).

  Without KVM it is running fine but slow. I'm operating Debian Jessie
  with qemu 2.1 for a long time with KVM virtualization working
  flawlessly. When I upgraded to Stretch I ran into the trouble
  described before. I tried Debian Stretch and Buster with all Kernels
  provided by the Board manufacturer (Hardkernel).

  It seems to be related to the feature introduced in Version 2.6:
  - Support for a separate EL3 address space

  KVM is enabled, so I assume the adress space index asidx to be causing
  the assert to fail.

  dmesg | grep -i KVM
  [    0.741714] kvm [1]: 8-bit VMID
  [    0.741721] kvm [1]: IDMAP page: 40201000
  [    0.741729] kvm [1]: HYP VA range: c0000000:ffffffff
  [    0.742543] kvm [1]: Hyp mode initialized successfully
  [    0.742600] kvm [1]: vgic-v2@10484000
  [    0.742924] kvm [1]: vgic interrupt IRQ16
  [    0.742943] kvm [1]: virtual timer IRQ60

  Full command line is:
  qemu-system-arm -M vexpress-a15 -smp 2 -m 512 -cpu host -enable-kvm -kernel 
vmlinuz -initrd initrd.gz -dtb vexpress-v2p-ca15-tc1.dtb -device 
virtio-blk-device,drive=inst-blk -drive 
file=PATHTOFILE,id=inst-blk,if=none,format=raw -append "vga=normal rw 
console=ttyAMA0" -nographic

  Is there anything to do to understand, if this is a hardware related
  failure or probably just a missing parameter?



To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]