[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Problems building and installing qemu v4.1.0-rc1 in sin

From: Guenter Roeck
Subject: Re: [Qemu-devel] Problems building and installing qemu v4.1.0-rc1 in single step
Date: Wed, 10 Jul 2019 18:07:42 -0700
User-agent: Mutt/1.5.24 (2015-08-30)

On Wed, Jul 10, 2019 at 03:01:53PM -0700, Guenter Roeck wrote:
> Hi,
> when trying to run "make -j30 install" from a clean tree on v4.1.0-rc0, I get
> _lots_ of undefined symbol errors.
> If I run "make -j30" followed by "make -j30 install", make succeeds, but then
> I get linker errors such as the following when running "make -j30 install".
> /usr/bin/ld: final link failed: File truncated
> /usr/bin/ld: BFD (GNU Binutils for Ubuntu) 2.26.1 internal error,
>       aborting at ../../bfd/merge.c:905 in _bfd_merged_section_offset
> Running "make -j30" followed by "make install" succeeds.

Correction: This doesn't always work either. Sometimes I still get a linker
error. If that happens, another round of "make; make install" succeeds.


> This looks like "make install" may have bad dependencies. Has anyone else
> experienced this problem ?
> Thanks,
> Guenter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]