[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH 1/2] vfio/mdev: add version field as mandatory a
Re: [Qemu-devel] [PATCH 1/2] vfio/mdev: add version field as mandatory attribute for mdev device
Tue, 7 May 2019 10:51:26 +0200
On Tue, 7 May 2019 01:39:13 -0400
Yan Zhao <address@hidden> wrote:
> On Tue, Apr 30, 2019 at 11:29:08PM +0800, Cornelia Huck wrote:
> > If I followed the discussion correctly, I think you plan to drop this
> > format, don't you? I'd be happy if a vendor driver can use a simple
> > number without any prefixes if it so chooses.
> > I also like the idea of renaming this "migration_version" so that it is
> > clear we're dealing with versioning of the migration capability (and
> > not a version of the device or so).
> hi Cornelia,
> sorry I just saw this mail after sending v2 of this patch set...
> yes, I dropped the common part and vendor driver now can define whatever it
> wishes to identify a device version.
Ok, I'll look at v2.
> However, I don't agree to rename it to "migration_version", as it still may
> bring some kind of confusing with the migration version a vendor driver is
> using, e.g. vendor driver changes migration code and increases that migration
> In fact, what info we want to get from this attribute is whether this mdev
> device is compatible with another mdev device, which is tied to device, and
> necessarily bound to migration.
> do you think so?
I'm not 100% convinced; but we can continue the discussion on v2.