[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PATCH v4 12/15] hw/mips/malta: Restrict 'bios_size' variab
From: |
Markus Armbruster |
Subject: |
[Qemu-devel] [PATCH v4 12/15] hw/mips/malta: Restrict 'bios_size' variable scope |
Date: |
Fri, 8 Mar 2019 10:46:07 +0100 |
From: Philippe Mathieu-Daudé <address@hidden>
The 'bios_size' variable is only used in the 'if (!kernel_filename &&
!dinfo)' clause. This is the case when we don't provide -pflash command
line option, and also don't provide a -kernel option. In this case we
will check for the -bios option, or use the default BIOS_FILENAME file.
The 'bios' term is valid in this if statement, but is confuse in the
whole mips_malta_init() scope. Restrict his scope.
Signed-off-by: Philippe Mathieu-Daudé <address@hidden>
Reviewed-by: Richard Henderson <address@hidden>
Signed-off-by: Markus Armbruster <address@hidden>
---
hw/mips/mips_malta.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/hw/mips/mips_malta.c b/hw/mips/mips_malta.c
index 51a3ecab59..4dfe06a1a0 100644
--- a/hw/mips/mips_malta.c
+++ b/hw/mips/mips_malta.c
@@ -1193,7 +1193,6 @@ void mips_malta_init(MachineState *machine)
MemoryRegion *ram_low_preio = g_new(MemoryRegion, 1);
MemoryRegion *ram_low_postio;
MemoryRegion *bios, *bios_copy = g_new(MemoryRegion, 1);
- target_long bios_size = FLASH_SIZE;
const size_t smbus_eeprom_size = 8 * 256;
uint8_t *smbus_eeprom_buf = g_malloc0(smbus_eeprom_size);
int64_t kernel_entry, bootloader_run_addr;
@@ -1301,6 +1300,7 @@ void mips_malta_init(MachineState *machine)
bootloader_run_addr, kernel_entry);
}
} else {
+ target_long bios_size = FLASH_SIZE;
/* The flash region isn't executable from a KVM guest */
if (kvm_enabled()) {
error_report("KVM enabled but no -kernel argument was specified. "
--
2.17.2
- Re: [Qemu-devel] [PATCH v4 09/15] r2d: Fix flash memory size, sector size, width, device ID, (continued)
- [Qemu-devel] [PATCH v4 11/15] hw/mips/malta: Remove fl_sectors variable, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 03/15] pflash_cfi01: Log use of flawed "write to buffer", Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 01/15] pflash: Rename pflash_t to PFlashCFI01, PFlashCFI02, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 06/15] sam460ex: Don't size flash memory to match backing image, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 08/15] ppc405_boards: Don't size flash memory to match backing image, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 05/15] hw: Use PFLASH_CFI0{1, 2} and TYPE_PFLASH_CFI0{1, 2}, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 13/15] mips_malta: Clean up definition of flash memory size somewhat, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 12/15] hw/mips/malta: Restrict 'bios_size' variable scope,
Markus Armbruster <=
- [Qemu-devel] [PATCH v4 14/15] pflash: Clean up after commit 368a354f02b, part 1, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 04/15] pflash: Rename *CFI_PFLASH* to *PFLASH_CFI*, Markus Armbruster, 2019/03/08
- [Qemu-devel] [PATCH v4 15/15] pflash: Clean up after commit 368a354f02b, part 2, Markus Armbruster, 2019/03/08