[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] [PULL v2 32/44] disas: nanoMIPS: Comment the decoder of 'gp
From: |
Aleksandar Markovic |
Subject: |
[Qemu-devel] [PULL v2 32/44] disas: nanoMIPS: Comment the decoder of 'gpr4.zero' gpr encoding type |
Date: |
Mon, 31 Dec 2018 15:56:28 +0100 |
From: Aleksandar Markovic <address@hidden>
Comment the decoder of 'gpr4.zero' gpr encoding type in nanoMIPS
disassembler.
Reviewed-by: Aleksandar Rikalo <address@hidden>
Signed-off-by: Aleksandar Markovic <address@hidden>
---
disas/nanomips.cpp | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
diff --git a/disas/nanomips.cpp b/disas/nanomips.cpp
index 66b1223..de96125 100644
--- a/disas/nanomips.cpp
+++ b/disas/nanomips.cpp
@@ -397,6 +397,33 @@ uint64 NMD::encode_rd1_from_rd(uint64 d)
}
+/*
+ * NMD::decode_gpr_gpr4_zero() - decoder for 'gpr4.zero' gpr encoding type
+ *
+ * Map a 4-bit code to the 5-bit register space according to this pattern:
+ *
+ * 1 0
+ * 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
+ * | | | | | | | | | | | | | | | |
+ * | | | | | | | | | | | | └---------------------┐
+ * | | | | | | | | | | | └---------------┐ |
+ * | | | | | | | | | | └---------------┐ | |
+ * | | | | | | | | | └---------------┐ | | |
+ * | | | | | | | | └---------------┐ | | | |
+ * | | | | | | | | | | | | | | | |
+ * | | | | | | | | | | | | | | | |
+ * 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
+ * 3 2 1 0
+ *
+ * This pattern is the same one used for 'gpr4' gpr encoding type, except for
+ * the input value 3, that is mapped to the output value 0 instead of 11.
+ *
+ * Used in handling following instructions:
+ *
+ * - MOVE.BALC
+ * - MOVEP
+ * - SW[4X4]
+ */
uint64 NMD::decode_gpr_gpr4_zero(uint64 d)
{
static uint64 register_list[] = { 8, 9, 10, 0, 4, 5, 6, 7,
--
2.7.4
- [Qemu-devel] [PULL v2 20/44] disas: nanoMIPS: Fix an FP-related misnomer 1, (continued)
- [Qemu-devel] [PULL v2 20/44] disas: nanoMIPS: Fix an FP-related misnomer 1, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 23/44] disas: nanoMIPS: Name more functions in a more descriptive way, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 22/44] disas: nanoMIPS: Fix an FP-related misnomer 3, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 21/44] disas: nanoMIPS: Fix an FP-related misnomer 2, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 19/44] disas: nanoMIPS: Name some functions in a more descriptive way, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 17/44] disas: nanoMIPS: Fix a function misnomer, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 24/44] disas: nanoMIPS: Fix order of more invocations, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 31/44] disas: nanoMIPS: Rename the decoder of 'gpr4.zero' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 29/44] disas: nanoMIPS: Rename the decoder of 'gpr4' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 30/44] disas: nanoMIPS: Comment the decoder of 'gpr4' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 32/44] disas: nanoMIPS: Comment the decoder of 'gpr4.zero' gpr encoding type,
Aleksandar Markovic <=
- [Qemu-devel] [PULL v2 37/44] disas: nanoMIPS: Rename the decoder of 'gpr1' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 34/44] disas: nanoMIPS: Comment the decoder of 'gpr2.reg1' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 36/44] disas: nanoMIPS: Comment the decoder of 'gpr2.reg2' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 43/44] tests/tcg: mips: Test R5900 three-operand MADDU, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 35/44] disas: nanoMIPS: Rename the decoder of 'gpr2.reg2' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 33/44] disas: nanoMIPS: Rename the decoder of 'gpr2.reg1' gpr encoding type, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 42/44] tests/tcg: mips: Test R5900 three-operand MADD1, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 41/44] tests/tcg: mips: Test R5900 three-operand MADD, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 40/44] disas: nanoMIPS: Add a note on documentation, Aleksandar Markovic, 2018/12/31
- [Qemu-devel] [PULL v2 38/44] disas: nanoMIPS: Comment the decoder of 'gpr1' gpr encoding type, Aleksandar Markovic, 2018/12/31