qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 0/4] Rewrite TCP packet comparison in colo


From: Mao Zhongyi
Subject: [Qemu-devel] [PATCH v2 0/4] Rewrite TCP packet comparison in colo
Date: Wed, 6 Dec 2017 17:57:24 +0800

In this series, mainly rewrite the tcp packet comparison based on 
the tcp sequence number instead of original method that compare the
packet based on the payload size.

v2:
  p1: a new patch
  p2: a new patch
  p3: -rename the fill_pkt_seq to fill_pkt_tcp_info
      -rename pdsize & hdsize to payload_size & header_size
      -reuse duplicated code
      -modified colo_packet_compare_common() to suit the tcp packet
       comparison instead of build a new function service for tcp.
      -add more comments for the 'max_ack'
                                                [Zhang Chen]

Cc: Zhang Chen <address@hidden>
Cc: Li Zhijian <address@hidden>
Cc: Jason Wang <address@hidden>

Mao Zhongyi (4):
  colo: remove the incorrect if conditions in colo_compare_packet_tcp()
  colo: modified the payload compare function
  colo: compare the packet based on the tcp sequence number
  colo: add trace for the tcp packet comparison

 net/colo-compare.c | 353 ++++++++++++++++++++++++++++++++++-------------------
 net/colo.c         |   9 ++
 net/colo.h         |  15 +++
 net/trace-events   |   2 +-
 4 files changed, 250 insertions(+), 129 deletions(-)

-- 
2.9.4






reply via email to

[Prev in Thread] Current Thread [Next in Thread]