[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Commit 77af8a2b95b79699de650965d5228772743efe84 breaks

From: BALATON Zoltan
Subject: Re: [Qemu-devel] Commit 77af8a2b95b79699de650965d5228772743efe84 breaks Windows 2000 support
Date: Fri, 21 Jul 2017 19:17:17 +0200 (CEST)
User-agent: Alpine 2.21 (BSF 202 2017-01-01)

On Fri, 21 Jul 2017, Phil Dennis-Jordan wrote:
On Fri, Jul 21, 2017 at 12:50 PM, BALATON Zoltan <address@hidden> wrote:
I don't know if this helps but I've found that this same commit also broke
booting OS X on q35 with OVMF and Clover (some old versions I had and worked
before this commit). See here:

Maybe it's simpler to debug as these are open source but it's still not very
clear why they fail because it starts to boot OS X but hangs during kernel
init (and maybe Win2K fails to boot because of something else). I think I've
seen this with OVMF 58f025afd and Clover 3354 (or around that, not
completely sure about these versions).

OVMF had 2 bugs that totally mucked up the ACPI tables if Qemu didn't
supply its loader commands "just so", and modified ACPI 2.0-5.0 FADTs
in such a way that they were no longer valid. These are fixed in
198a46d and 072060a, which are about a year newer than 58f025afd, so
it's no surprise this combination doesn't work. I have no idea if
Clover on top makes any difference.

I've tried with 072060a and with that version OS X boots with same Clover so my problem seems to have been too old OVMF version and Clover does not make a difference here. So this also likely has nothing do with the Win2k problem discussed in this thread so you can disregard my post.

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]