qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v9 05/12] vfio: Introduce common function to add


From: Kirti Wankhede
Subject: Re: [Qemu-devel] [PATCH v9 05/12] vfio: Introduce common function to add capabilities
Date: Tue, 25 Oct 2016 02:57:58 +0530


On 10/21/2016 12:54 AM, Alex Williamson wrote:
> On Tue, 18 Oct 2016 02:52:05 +0530
> Kirti Wankhede <address@hidden> wrote:
> 
>> Vendor driver using mediated device framework should use
>> vfio_info_add_capability() to add capabilities.
>> Introduced this function to reduce code duplication in vendor drivers.
>>
>> Signed-off-by: Kirti Wankhede <address@hidden>
>> Signed-off-by: Neo Jia <address@hidden>
>> Change-Id: I6fca329fa2291f37a2c859d0bc97574d9e2ce1a6
>> ---
>>  drivers/vfio/vfio.c  | 78 
>> ++++++++++++++++++++++++++++++++++++++++++++++++++++
>>  include/linux/vfio.h |  4 +++
>>  2 files changed, 82 insertions(+)
>>
>> diff --git a/drivers/vfio/vfio.c b/drivers/vfio/vfio.c
>> index a5a210005b65..e96cb3f7a23c 100644
>> --- a/drivers/vfio/vfio.c
>> +++ b/drivers/vfio/vfio.c
>> @@ -1799,6 +1799,84 @@ void vfio_info_cap_shift(struct vfio_info_cap *caps, 
>> size_t offset)
>>  }
>>  EXPORT_SYMBOL_GPL(vfio_info_cap_shift);
>>  
>> +static int sparse_mmap_cap(struct vfio_info_cap *caps, void *cap_type)
>> +{
>> +    struct vfio_info_cap_header *header;
>> +    struct vfio_region_info_cap_sparse_mmap *sparse_cap, *sparse = cap_type;
>> +    size_t size;
>> +
>> +    size = sizeof(*sparse) + sparse->nr_areas *  sizeof(*sparse->areas);
>> +    header = vfio_info_cap_add(caps, size,
>> +                               VFIO_REGION_INFO_CAP_SPARSE_MMAP, 1);
>> +    if (IS_ERR(header))
>> +            return PTR_ERR(header);
>> +
>> +    sparse_cap = container_of(header,
>> +                    struct vfio_region_info_cap_sparse_mmap, header);
>> +    sparse_cap->nr_areas = sparse->nr_areas;
>> +    memcpy(sparse_cap->areas, sparse->areas,
>> +           sparse->nr_areas * sizeof(*sparse->areas));
>> +    return 0;
>> +}
>> +
>> +static int region_type_cap(struct vfio_info_cap *caps, void *cap_type)
>> +{
>> +    struct vfio_info_cap_header *header;
>> +    struct vfio_region_info_cap_type *type_cap, *cap = cap_type;
>> +
>> +    header = vfio_info_cap_add(caps, sizeof(*cap),
>> +                               VFIO_REGION_INFO_CAP_TYPE, 1);
>> +    if (IS_ERR(header))
>> +            return PTR_ERR(header);
>> +
>> +    type_cap = container_of(header, struct vfio_region_info_cap_type,
>> +                            header);
>> +    type_cap->type = cap->type;
>> +    type_cap->subtype = cap->subtype;
>> +    return 0;
>> +}
>> +
>> +int vfio_info_add_capability(struct vfio_region_info *info,
>> +                         struct vfio_info_cap *caps,
>> +                         int cap_type_id,
>> +                         void *cap_type)
>> +{
>> +    int ret;
>> +
>> +    if (!cap_type)
>> +            return 0;
>> +
>> +    switch (cap_type_id) {
>> +    case VFIO_REGION_INFO_CAP_SPARSE_MMAP:
>> +            ret = sparse_mmap_cap(caps, cap_type);
>> +            if (ret)
>> +                    return ret;
>> +            break;
>> +
>> +    case VFIO_REGION_INFO_CAP_TYPE:
>> +            ret = region_type_cap(caps, cap_type);
>> +            if (ret)
>> +                    return ret;
>> +            break;
>> +    default:
>> +            return -EINVAL;
>> +    }
>> +
>> +    info->flags |= VFIO_REGION_INFO_FLAG_CAPS;
>> +
>> +    if (caps->size) {
>> +            if (info->argsz < sizeof(*info) + caps->size) {
>> +                    info->argsz = sizeof(*info) + caps->size;
>> +                    info->cap_offset = 0;
>> +            } else {
>> +                    vfio_info_cap_shift(caps, sizeof(*info));
>> +                    info->cap_offset = sizeof(*info);
> 
> This doesn't work.  We build the capability chain in a buffer and
> vfio_info_cap_add() expects the chain to be zero-based as each
> capability is added.  vfio_info_cap_shift() is meant to be called once
> on that buffer immediately before copying it back to the user buffer to
> adjust the chain offsets to account for the offset within the buffer.
> vfio_info_cap_shift() cannot be called repeatedly on the buffer as we
> do support multiple capabilities in a chain.
> 

>From the code I see, we add one type of capability at a time, either
VFIO_REGION_INFO_CAP_SPARSE_MMAP or VFIO_REGION_INFO_CAP_TYPE. Both are
not the part of same case in the switch, right?
I do tested VFIO_REGION_INFO_CAP_SPARSE_MMAP by mapping some part of
BAR0 and that works.

Kirti.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]