qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v20 0/5] block/gluster: add support for multiple


From: Jeff Cody
Subject: Re: [Qemu-devel] [PATCH v20 0/5] block/gluster: add support for multiple gluster servers
Date: Tue, 19 Jul 2016 17:40:59 -0400
User-agent: Mutt/1.5.24 (2015-08-30)

On Tue, Jul 19, 2016 at 10:27:28PM +0530, Prasanna Kumar Kalever wrote:
> This version of patches are rebased repo at
> git://repo.or.cz/qemu/armbru.git qapi-not-next
> 
> Prasanna Kumar Kalever (5):
>   block/gluster: rename [server, volname, image] -> [host, volume, path]
>   block/gluster: code cleanup
>   block/gluster: deprecate rdma support
>   block/gluster: using new qapi schema
>   block/gluster: add support for multiple gluster servers
> 
> v1:
> multiple host addresses but common port number and transport type
> pattern: URI syntax with query (?) delimitor
> syntax:
>     file=gluster[+transport-type]://host1:24007/testvol/a.img\
>          ?server=host2&server=host3
> 
> v2:
> multiple host addresses each have their own port number, but all use
>                                                          common transport type
> pattern: URI syntax  with query (?) delimiter
> syntax:
>     file=gluster[+transport-type]://[host[:port]]/testvol/a.img\
>          [?server=host1[:port]\
>           &server=host2[:port]]
> 
> v3:
> multiple host addresses each have their own port number and transport type
> pattern: changed to json
> syntax:
>     'json:{"driver":"qcow2","file":{"driver":"gluster","volume":"testvol",
>            "path":"/path/a.qcow2","server":
>          [{"host":"1.2.3.4","port":"24007","transport":"tcp"},
>           {"host":"4.5.6.7","port":"24008","transport":"rdma"}] } }'
> 
> v4, v5:
> address comments from "Eric Blake" <address@hidden>
> renamed:
> 'backup-volfile-servers' -> 'volfile-servers'
> 
> v6:
> address comments from Peter Krempa <address@hidden>
> renamed:
>  'volname'    ->  'volume'
>  'image-path' ->  'path'
>  'server'     ->  'host'
> 
> v7:
> fix for v6 (initialize num_servers to 1 and other typos)
> 
> v8:
> split patch set v7 into series of 3 as per Peter Krempa <address@hidden>
> review comments
> 
> v9:
> reorder the series of patches addressing "Eric Blake" <address@hidden>
> review comments
> 
> v10:
> fix mem-leak as per Peter Krempa <address@hidden> review comments
> 
> v11:
> using qapi-types* defined structures as per "Eric Blake" <address@hidden>
> review comments.
> 
> v12:
> fix crash caused in qapi_free_BlockdevOptionsGluster
> 
> v13:
> address comments from "Jeff Cody" <address@hidden>
> 
> v14:
> address comments from "Eric Blake" <address@hidden>
> split patch 3/3 into two
> rename input option and variable from 'servers' to 'server'
> 
> v15:
> patch 1/4 changed the commit message as per Eric's comment
> patch 2/4 are unchanged
> patch 3/4 addressed Jeff's comments
> patch 4/4 concentrates on unix transport related help info,
> rename 'parse_transport_option()' to 'qapi_enum_parse()',
> address memory leaks and other comments given by Jeff and Eric
> 
> v16:
> In patch 4/4 fixed segfault on glfs_init() error case, as per Jeff's comments
> other patches in this series remain unchanged
> 
> v17:
> rebase of v16 on latest master
> 
> v18:
> rebase of v17 on latest master
> rebase has demanded type conversion of 'qemu_gluster_init()'[s] first argument
> from 'BlockdevOptionsGluster**' to 'BlockdevOptionsGluster*' and all its 
> callees
> both in 3/4 and 4/4 patches
> 
> v19:
> patches 1/5, 2/5 remains unchanged
> 
> patch 3/5 is something new, in which the rdma deadcode is removed
> 
> patch 4/5 (i.e. 3/4 in v18) now uses union discriminator, I have made a choice
> to use gluster with custom schema since @UnixSocketAddress uses 'path' as key,
> which may be confusing with gluster, and in @InetSocketAddress port was str
> again I have made a choice to keep it uint16 which really make sense.
> Hmmm.. As Markus suggested in v18 qemu_gluster_parseuri() is *parse_uri() same
> with *parse_json() (in 5/5)
> 
> patch 5/5 (i.e 4/4 in v18) adds a list of servers and json parser 
> functionality
> as usual
> 
> Thanks to Markus and Eric for help in understanding the new schema changes.
> 
> v20:
> address comments from Markus and Eric on v19
> patch 4/5 and 5/5 Use InetSocketAddress instead of GlusterInetSocketAddress
> Port is not optional anymore
> 
>  block/gluster.c      | 637 
> +++++++++++++++++++++++++++++++++++++++------------
>  qapi/block-core.json |  68 +++++-
>  2 files changed, 553 insertions(+), 152 deletions(-)
> 
> -- 
> 2.7.4
> 

Thanks,

Applied to my block branch:

git://github.com/codyprime/qemu-kvm-jtc.git block

-Jeff



reply via email to

[Prev in Thread] Current Thread [Next in Thread]