qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v6 02/11] fix some coding style problems


From: Cao jin
Subject: Re: [Qemu-devel] [PATCH v6 02/11] fix some coding style problems
Date: Wed, 1 Jun 2016 16:33:57 +0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.1.0



On 06/01/2016 04:09 PM, Markus Armbruster wrote:
Cao jin <address@hidden> writes:

It has:
1. More newlines make the code block well separated.
2. Add more comments for msi_init.
3. Fix a indentation in vmxnet3.c.
4. ioh3420 & xio3130_downstream: put PCI Express capability init function
    together, make it more readable.

cc: Dmitry Fleytman <address@hidden>
cc: Jason Wang <address@hidden>
cc: Michael S. Tsirkin <address@hidden>
cc: Markus Armbruster <address@hidden>
cc: Marcel Apfelbaum <address@hidden>

Reviewed-by: Marcel Apfelbaum <address@hidden>
Signed-off-by: Cao jin <address@hidden>
[...]
diff --git a/hw/pci/msi.c b/hw/pci/msi.c
index e0e64c2..97f35c0 100644
--- a/hw/pci/msi.c
+++ b/hw/pci/msi.c
@@ -165,6 +165,23 @@ bool msi_enabled(const PCIDevice *dev)
           PCI_MSI_FLAGS_ENABLE);
  }

+/*
+ * Make PCI device @dev MSI-capable.
+ * Non-zero @offset puts capability MSI at that offset in PCI config
+ * space.
+ * @nr_vectors is the number of MSI vectors (1, 2, 4, 8, 16 or 32).
+ * If @msi64bit, make the device capable of sending a 64-bit message
+ * address.
+ * If @msi_per_vector_mask, make the device support per-vector masking.
+ * @errp is for returning errors.

@errp only appears in PATCH 11.  The easiest fix is to add this comment
only then.


eh...sorry for my carelessness...

--
Yours Sincerely,

Cao jin





reply via email to

[Prev in Thread] Current Thread [Next in Thread]