[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v7 03/19] block: Switch blk_*write_zeroes() to b

From: Kevin Wolf
Subject: Re: [Qemu-devel] [PATCH v7 03/19] block: Switch blk_*write_zeroes() to byte interface
Date: Mon, 23 May 2016 17:42:06 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

Am 06.05.2016 um 18:26 hat Eric Blake geschrieben:
> Sector-based blk_write() should die; convert the one-off
> variant blk_write_zeroes() to use an offset/count interface
> instead.  Likewise for blk_co_write_zeroes() and
> blk_aio_write_zeroes().
> Signed-off-by: Eric Blake <address@hidden>

You built a nice trap here: bdrv_*write_zeroes() is still sector based
whereas blk_*write_zeroes() changed to be byte based without a rename.
That broke my block jobs series which converts from bdrv_* to blk_*
after the next (seemingly clean) rebase.

I fixed my series now, but can we please convert bdrv_* as well
before we get more victims in the same trap? Also (and perhaps more
importantly) we could rename the functions to something like
blk_*pwrite_zeroes(), indicating the switch to byte based.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]