[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 4/5] Change return type of functions that are

From: Cornelia Huck
Subject: Re: [Qemu-devel] [PATCH v2 4/5] Change return type of functions that are named *_exit or *_exitfn in hw/s390x from int to void
Date: Wed, 13 Apr 2016 12:46:04 +0200

On Tue, 12 Apr 2016 23:57:06 +0530
Nutan Shinde <address@hidden> wrote:

> This change is required because the return type of exit(error) function is
> not used.
> This patch only has changes for files in hw/s390x package.

Some meta-notes (I saw the related discussion on qemu-devel; the
comments there apply to this patch as well):

- The change is not 'required'. It's a cleanup because everybody
  returns 0 anyway.
- It often makes sense to cc: everybody on the cover letter so they can
  find out what the series is about without needing to dig it up on the
  mailing list.
- A patch series needs to preserve bisectability, i.e. at every point
  in the series the code must compile.
  To achieve this, it often makes sense to split out self-contained
  changes restricted to a component (here: changes following from
  VirtIOCCWDeviceClass changes) from whole-tree changes (here: changes
  following from DeviceClass).

> Signed-off-by: Nutan Shinde <address@hidden>
> ---
>  hw/s390x/virtio-ccw.c | 7 +++----
>  hw/s390x/virtio-ccw.h | 2 +-
>  2 files changed, 4 insertions(+), 5 deletions(-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]