qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Fwd: [PATCH v2 3/5] Change return type of functions that ar


From: Nutan Shinde
Subject: [Qemu-devel] Fwd: [PATCH v2 3/5] Change return type of functions that are named *_exit or *_exitfn in hw/core from int to void
Date: Tue, 12 Apr 2016 23:52:38 +0530


This change is required because the return type of exit(error) function is not used.
This patch only has changes for files in hw/core package.

Signed-off-by: Nutan Shinde <address@hidden>
---
 hw/core/qdev.c | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/hw/core/qdev.c b/hw/core/qdev.c
index db41aa1..7495fcf 100644
--- a/hw/core/qdev.c
+++ b/hw/core/qdev.c
@@ -237,11 +237,7 @@ static void device_unrealize(DeviceState *dev, Error **errp)
     DeviceClass *dc = DEVICE_GET_CLASS(dev);

     if (dc->exit) {
-        int rc = dc->exit(dev);
-        if (rc < 0) {
-            error_setg(errp, "Device exit failed.");
-            return;
-        }
+        dc->exit(dev);
     }
 }

--
1.9.1



reply via email to

[Prev in Thread] Current Thread [Next in Thread]