[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] net/filter: rename qemu_netfilter_pass_to_next(

From: Jason Wang
Subject: Re: [Qemu-devel] [PATCH] net/filter: rename qemu_netfilter_pass_to_next() to qemu_netfilter_iterate()
Date: Tue, 15 Mar 2016 11:08:49 +0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1

On 03/09/2016 04:02 PM, Li Zhijian wrote:
> On 03/08/2016 04:04 PM, Yang Hongyang wrote:
>> Hi Chen,
>>    What's the motivation that you want to change this name? The
>> function actually is not
>> intent to iterate every filter.
> Right. but this function isn't always pass packet to *a* next filter.
> Actually, it iterates filters until the packet is stolen(filter
> receiving handler return non-zero).
> In other words, packet could be handled by several filters at this
> function.
> BTW, it's difficult to determine what name is better.
> Thanks
> Li Zhijian 

Right, so I was considering a better function name (though I'm not a
native English speaker).

But I agree qemu_netfilter_iterate() is not perfect too, may need more

reply via email to

[Prev in Thread] Current Thread [Next in Thread]