[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH v4 4/4] migration: Expose 'cancelling' status to
Dr. David Alan Gilbert
Re: [Qemu-devel] [PATCH v4 4/4] migration: Expose 'cancelling' status to user
Fri, 13 Mar 2015 12:28:08 +0000
* Eric Blake (address@hidden) wrote:
> On 03/13/2015 04:49 AM, Paolo Bonzini wrote:
> > On 09/03/2015 07:45, zhanghailiang wrote:
> >> 'cancelling' status was introduced by commit 51cf4c1a, mainly to avoid a
> >> possible start of a new migration process while the previous one still
> >> exists.
> >> But we didn't expose this status to user, instead we returned the 'active'
> >> state.
> >> Here, we expose it to the user (such as libvirt), 'cancelling' status only
> >> occurs for a short window before the migration aborts, so for users,
> >> if they cancel a migration process, it will observe 'cancelling' status
> >> occasionally.
> >> Testing revealed that with older libvirt (anything 1.2.13 or less) will
> >> print an odd error message if the state is seen, but that the migration
> >> is still properly cancelled. Newer libvirt will be patched to recognize
> >> the new state without the odd error message.
> >> Signed-off-by: zhanghailiang <address@hidden>
> >> Reviewed-by: Eric Blake <address@hidden>
> >> Cc: address@hidden
> > Why is this necessary?
> It simplifies qemu's job of reporting migration status information (qemu
> is no longer maintaining one set of states internally and a different
> set of states externally), and I already have the libvirt counterpart
> patch ready to go to gracefully accept the new state name.
Yes, it does make life simpler in the long run.
(It does worry me a bit what happens to new qemu on old libvirt)
> Eric Blake eblake redhat com +1-919-301-3266
> Libvirt virtualization library http://libvirt.org
Dr. David Alan Gilbert / address@hidden / Manchester, UK
[Qemu-devel] [PATCH v4 3/4] migration: Convert 'status' of MigrationInfo to use an enum type, zhanghailiang, 2015/03/09
[Qemu-devel] [PATCH v4 1/4] migration: Rename abbreviated macro MIG_STATE_* to MIGRATION_STATUS_*, zhanghailiang, 2015/03/09
[Qemu-devel] [PATCH v4 2/4] hmp: Rename 'MigrationStatus' to 'HMPMigrationStatus', zhanghailiang, 2015/03/09
Re: [Qemu-devel] [PATCH v4 0/4] Convert 'status' of MigrationInfo from open-coded 'str' to enum type, zhanghailiang, 2015/03/11