qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [v2][PATCH 2/2] libxl: introduce gfx_passthru_kind


From: Chen, Tiejun
Subject: Re: [Qemu-devel] [v2][PATCH 2/2] libxl: introduce gfx_passthru_kind
Date: Fri, 13 Mar 2015 09:39:38 +0800
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

I don't think you can abort here, since a user can set
b_info->u.hvm.gfx_passthru_kind to default. You would need to return an
error.

Then, looks I should do this,

                    LOG(ERROR, "No supported IGD to passthru,"
                        " or please force set gfx_passthru=\"igd\".\n");
                    return NULL;


@@ -720,6 +720,13 @@ void libxl_mac_copy(libxl_ctx *ctx, libxl_mac *dst,
libxl_mac *src);
   #define LIBXL_HAVE_PSR_MBM 1
   #endif

+/*
+ * LIBXL_HAVE_GFX_PASSTHRU_KIND
+ *
+ * If this is defined, the Graphic Device Passthrough Override is
supported.

Almost, please also explicitly name the type field as other similar
comments do for clarity.

Okay, maybe something is like this,

+/*
+ * LIBXL_HAVE_IGD_GFX_PASSTHRU
+ *
+ * If this is defined, the IGD Graphic Device Passthrough is supported.
+ *
+ * LIBXL_HAVE_IGD_GFX_PASSTHRU indicates that the
+ * libxl_device_pci field in the hvm is present in the pci_info structure
+ * fixup_ids[] which contains all supported IGD devices. So wwe use
+ * "igd-passthru=on" specify on the qemu command-line.
+ */
+#define LIBXL_HAVE_IGD_GFX_PASSTHRU 1
+

+ */

[snip]

and this should be in libxl_internal.h not here...

Okay.

I mistakenly understand we always have to expose this in libxl.h...


But looks libxl__gc{} is defined in the libxl_internal.h file... I guess

[snip]

+        if (!xlu_cfg_get_long(config, "gfx_passthru", &l, 1)) {
+            if (l) {
+                libxl_defbool_set(&b_info->u.hvm.gfx_passthru, true);
+            } else {
+                libxl_defbool_set(&b_info->u.hvm.gfx_passthru, false);
+            }

This is exactly the same as:
         libxl_defbool_set(&b_info->u.hvm.gfx_passthru, l);


Sure.

Thanks
Tiejun



reply via email to

[Prev in Thread] Current Thread [Next in Thread]