[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 6/6] rename save_block_hdr to save_page_header

From: Juan Quintela
Subject: Re: [Qemu-devel] [PATCH 6/6] rename save_block_hdr to save_page_header
Date: Thu, 12 Mar 2015 16:44:49 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.4 (gnu/linux)

Amit Shah <address@hidden> wrote:
> On (Thu) 12 Feb 2015 [23:03:11], Juan Quintela wrote:
>> It has always been a page header, not a block header.  Once there, the
>> flag argument was only passed to make a bit or with it, just do the or
>> on the caller.
> I prefer not to do that -- if one looks at the function signature,
> he'll only notice 'offset' there and not 'offset|flag', so it's
> confusing to callers of function why the | is being done for an offset
> field.

Problem with that is offset, at this point is an opaque from the
callee.  The only thing that they can do with it is just to add another
valid flag.  We can rename it if you want, but that don't change the
fact that it is not useable there.

Basically we have RAMBlocks, where we have an offset inside that
RAMBlock.  We get to ram_save_page() and convert that offset into a
pointer in host ram with memory_region_get_ram_ptr().  From there on,
offset is something that can't be used anymore as offset, is just opaque
to be able to reproduce it on the target machine.

id? token?  anyother better name?

Later, Juan.

> Let's keep that bit as-is?
>               Amit

reply via email to

[Prev in Thread] Current Thread [Next in Thread]